summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 20:14:06 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:03 -0400
commita9e9d9f41ce4c82098c27f14e98d13afb6b53b97 (patch)
tree0693d0b34b46e846c725d073ea4f0f821d3854e7
parent7cd3a88f27b4d90b18cba1dd1fd1e1b9cc4c8f8e (diff)
downloadguix-patches-a9e9d9f41ce4c82098c27f14e98d13afb6b53b97.tar
guix-patches-a9e9d9f41ce4c82098c27f14e98d13afb6b53b97.tar.gz
gnu: lvtk: Update to 1.2.0-0.a73feab.
* gnu/packages/audio.scm (lvtk): Update to 1.2.0-0.a73feab. [python]: Delete argument. [configure-flags]: Likewise. [inputs]: Replace gtkmm-2 by gtkmm. [license]: Change license to isc.
-rw-r--r--gnu/packages/audio.scm56
1 files changed, 26 insertions, 30 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 844d4c63f3..1ba93afdfb 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 okapi <okapi@firemail.cc>
-;;; Copyright © 2018, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
@@ -2801,37 +2801,33 @@ software.")
(description "An LV2 port of the mda EPiano VSTi.")))
(define-public lvtk
- (package
- (name "lvtk")
- (version "1.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lvtk/lvtk")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1b01zvzl70ana6l1kn8fgyr7msnn3c7x61cgw7fdpp50322352p8"))))
- (build-system waf-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:python ,python-2
- #:configure-flags
- (list (string-append "--boost-includes="
- (assoc-ref %build-inputs "boost")
- "/include"))))
- (inputs
- (list boost gtkmm-2 lv2))
- (native-inputs
- (list pkg-config))
- (home-page "https://github.com/lvtk/lvtk")
- (synopsis "C++ libraries for LV2 plugins")
- (description
- "The LV2 Toolkit (LVTK) contains libraries that wrap the LV2 C API and
+ ;; Use the latest commit, as the latest release was made in 2014 and depends
+ ;; on Python 2.
+ (let ((commit "a73feabe772f9650aa071e6a4df660e549ab7c48")
+ (revision "0"))
+ (package
+ (name "lvtk")
+ (version (git-version "1.2.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lvtk/lvtk")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0scmv8b4jlm88d21dqqchjy98wb93zclc9x960h213gdi871vsaj"))))
+ (build-system waf-build-system)
+ (arguments (list #:tests? #f)) ;no check target
+ (inputs (list boost gtkmm lv2))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/lvtk/lvtk")
+ (synopsis "C++ libraries for LV2 plugins")
+ (description
+ "The LV2 Toolkit (LVTK) contains libraries that wrap the LV2 C API and
extensions into easy to use C++ classes. It is the successor of
lv2-c++-tools.")
- (license license:gpl3+)))
+ (license license:isc))))
(define-public openal
(package