summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 16:34:56 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:15 -0400
commita55151703f060239ef1bcd080e29bdcddc4e21d7 (patch)
tree8fe2fbb4bf38449103cd7cf551d26e4fe7d52597
parentb89669f0346888a556061cb35b4a74b13ee3daa4 (diff)
downloadguix-patches-a55151703f060239ef1bcd080e29bdcddc4e21d7.tar
guix-patches-a55151703f060239ef1bcd080e29bdcddc4e21d7.tar.gz
gnu: python2-six: Disable tests.
* gnu/packages/python-xyz.scm (python2-six)[native-inputs]: Clear. [phases]: Delete check phase.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fbb0fc399b..74becc7997 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2573,7 +2573,16 @@ in the current session, Python, and the OS.")
`(("python-pytest" ,python-pytest-bootstrap)))))
(define-public python2-six
- (package-with-python2 python-six))
+ (let ((base (package-with-python2 python-six)))
+ (package
+ (inherit base)
+ ;; Reduce Python 2 closure by disabling tests and removing the native
+ ;; inputs.
+ (arguments (substitute-keyword-arguments (package-arguments base)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (delete 'check)))))
+ (native-inputs '()))))
(define-public python-schedule
(package