summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-14 11:26:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:16 -0400
commit96c0c18c3e65b59f365b06e478fbcb71f272ed25 (patch)
tree2fd6150f681a9e7452f6b191ad619a0c4220606a
parent5d8fb87127beee50671a9506013be541a8b45ea8 (diff)
downloadguix-patches-96c0c18c3e65b59f365b06e478fbcb71f272ed25.tar
guix-patches-96c0c18c3e65b59f365b06e478fbcb71f272ed25.tar.gz
gnu: Remove python-prompt-toolkit-2.
* gnu/packages/python-xyz.scm (python-prompt-toolkit-2): Delete variable. (python-prompt-toolkit)[properties]: Delete field. (python-jupyter-console): Replace python-prompt-toolkit-2 with python-prompt-toolkit.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d59d353009..8088761f0f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16623,8 +16623,7 @@ interfaces in Python. It's like GNU Readline but it also features syntax
highlighting while typing, out-of-the-box multi-line input editing, advanced
code completion, incremental search, support for Chinese double-width
characters, mouse support, and auto suggestions.")
- (license license:bsd-3)
- (properties `((python2-variant . ,(delay python-prompt-toolkit-2))))))
+ (license license:bsd-3)))
(define-public python-proselint
(package
@@ -16653,21 +16652,6 @@ characters, mouse support, and auto suggestions.")
scans through a file and detects issues.")
(license license:bsd-3)))
-(define-public python-prompt-toolkit-2
- (package (inherit python-prompt-toolkit)
- (name "python-prompt-toolkit")
- (version "2.0.7")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "prompt_toolkit" version))
- (sha256
- (base32
- "0fgacqk73w7s932vy46pan2yp8rvjmlkag20xvaydh9mhf6h85zx"))))
- (propagated-inputs
- (list python-wcwidth python-six python-pygments))
- (properties '())))
-
(define-public python-jedi
(package
(name "python-jedi")