summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 13:50:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:10 -0400
commit425783b5dcec38842718829c9fe56741bbcfc567 (patch)
tree89f6cca466519d818fb118ec1657d5b2f469cab5
parent0b478a5d701f4794e46794967055d9e11c8bdfb2 (diff)
downloadguix-patches-425783b5dcec38842718829c9fe56741bbcfc567.tar
guix-patches-425783b5dcec38842718829c9fe56741bbcfc567.tar.gz
gnu: Remove python2-cython.
* gnu/packages/python-xyz.scm (python2-cython): Delete variable. (python-feedgenerator)[properties]: Delete field.
-rw-r--r--gnu/packages/python-xyz.scm37
1 files changed, 1 insertions, 36 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5fa13f01a4..e1627a960a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5313,42 +5313,7 @@ provides additional functionality on the produced Mallard documents.")
(description "Cython is an optimising static compiler for both the Python
programming language and the extended Cython programming language. It makes
writing C extensions for Python as easy as Python itself.")
- (license license:asl2.0)
- (properties `((python2-variant . ,(delay python2-cython))))))
-
-(define-public python2-cython
- (let ((base (package-with-python2 (strip-python2-variant python-cython))))
- (package/inherit base
- (name "python2-cython")
- (inputs
- `(("python-2" ,python-2))) ;this is not automatically changed
- (arguments
- (substitute-keyword-arguments (package-arguments base)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'check 'adjust-test_embed
- (lambda _
- (substitute* "runtests.py"
- ;; test_embed goes great lengths to find the static libpythonX.Y.a
- ;; so it can give the right -L flag to GCC when embedding static
- ;; builds of Python. It is unaware that the Python "config"
- ;; directory (where the static library lives) was renamed in
- ;; Python 3, and falls back to sysconfig.get_config_var('LIBDIR'),
- ;; which works fine, because that is where the shared library is.
- ;;
- ;; It also appears to be unaware that the Makefile in Demos/embed
- ;; already unconditionally pass the static library location to GCC,
- ;; after checking sysconfig.get_config_var('LIBPL).
- ;;
- ;; The effect is that the linker is unable to resolve libexpat
- ;; symbols when building for Python 2, because neither the Python 2
- ;; shared library nor Expat is available. To fix it, we can either
- ;; add Expat as an input and make it visible to the linker, or just
- ;; prevent it from overriding the Python shared library location.
- ;; The end result is identical, so we take the easy route.
- ((" or libname not in os\\.listdir\\(libdir\\)")
- ""))
- #t)))))))))
+ (license license:asl2.0)))
(define-public python-cython-3
(package