summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 15:37:06 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:14 -0400
commit28bddb7d4f0acb1ad8a61fd9dec7923487c0803c (patch)
tree3a0db42297bd6ca372fb30bc72e768496f463ce6
parent9165283a1cdd087d76b70563315eb59e8a608704 (diff)
downloadguix-patches-28bddb7d4f0acb1ad8a61fd9dec7923487c0803c.tar
guix-patches-28bddb7d4f0acb1ad8a61fd9dec7923487c0803c.tar.gz
gnu: Remove python2-pyparsing.
* gnu/packages/python-build.scm (python2-pyparsing): Delete variable. (python-pyparsing)[properties]: Delete field.
-rw-r--r--gnu/packages/python-build.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index c64a7732be..d85463ebab 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -261,8 +261,7 @@ Python file, so it can be easily copied into your project.")
executing simple grammars, vs. the traditional lex/yacc approach, or the use
of regular expressions. The pyparsing module provides a library of classes
that client code uses to construct the grammar directly in Python code.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-pyparsing))))))
+ (license license:expat)))
;;; This is the last release compatible with Python 2.
(define-public python-pyparsing-2.4.7
@@ -276,9 +275,6 @@ that client code uses to construct the grammar directly in Python code.")
(sha256
(base32 "1hgc8qrbq1ymxbwfbjghv01fm3fbpjwpjwi0bcailxxzhf3yq0y2"))))))
-(define-public python2-pyparsing
- (package-with-python2 (strip-python2-variant python-pyparsing-2.4.7)))
-
(define-public python-packaging-bootstrap
(package
(name "python-packaging-bootstrap")