summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 15:07:07 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:12 -0400
commit0fa989172df685170590e42b6eadc151cbd2acba (patch)
tree608c06bb74c1859b45e449d342ec40c0480af467
parent9c19bdbf5cb0da0579db19d2759b91f28fc00220 (diff)
downloadguix-patches-0fa989172df685170590e42b6eadc151cbd2acba.tar
guix-patches-0fa989172df685170590e42b6eadc151cbd2acba.tar.gz
gnu: Remove python2-nose.
* gnu/packages/check.scm (python2-nose): Delete variable. (python-nose)[properties]: Delete field.
-rw-r--r--gnu/packages/check.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index fdf14f7cf2..66e7993996 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -887,17 +887,7 @@ available via the @code{unittest.mock} module.")
(synopsis "Python testing library")
(description
"Nose extends the unittest library to make testing easier.")
- (license license:lgpl2.0+)
- (properties `((python2-variant . ,(delay python2-nose))))))
-
-(define-public python2-nose
- (let ((base (package-with-python2
- (strip-python2-variant python-nose))))
- (package/inherit base
- (arguments (substitute-keyword-arguments (package-arguments base)
- ((#:phases phases)
- `(modify-phases ,phases
- (delete 'invoke-2to3))))))))
+ (license license:lgpl2.0+)))
(define-public python-nose2
(package