summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 02:54:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:53 -0400
commit0f3cd86c67f767b7931871546bbac441483d0a1b (patch)
treef6ec6e1d7c8bc01f41d1e9879febb91e32d355b6
parent1a6b88192dba4aae27bc56f848f2ec42fa3d2eb5 (diff)
downloadguix-patches-0f3cd86c67f767b7931871546bbac441483d0a1b.tar
guix-patches-0f3cd86c67f767b7931871546bbac441483d0a1b.tar.gz
gnu: Remove python2-wxpython.
* gnu/packages/wxwidgets.scm (python2-wxpython): Delete variable.
-rw-r--r--gnu/packages/wxwidgets.scm73
1 files changed, 0 insertions, 73 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index ca1b33081d..4d2fd73cee 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -265,79 +265,6 @@ library. In most cases, wxPython uses the native widgets on each platform to
provide a 100% native look and feel for the application.")
(license l:wxwindows3.1+)))
-(define-public python2-wxpython
- (package
- (name "python2-wxpython")
- (version "3.0.2.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/wxpython/wxPython/"
- version "/wxPython-src-" version ".tar.bz2"))
- (sha256
- (base32
- "0qfzx3sqx4mwxv99sfybhsij4b5pc03ricl73h4vhkzazgjjjhfm"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (lambda (folder)
- (delete-file-recursively (string-append "src/" folder))
- '("expat" "jpeg" "png" "tiff" "zlib" "msw" "osx" "msdos"))
- (substitute* '("wxPython/setup.py")
- ;; setup.py tries to keep its own license the same as wxwidget's
- ;; license (which it expects under $WXWIN/docs).
- (("'preamble.txt', 'licence.txt', 'licendoc.txt', 'lgpl.txt'")
- ""))
- #t))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:tests? #f ; tests fail
- ;; wxPython directly extends distutils command classes,
- ;; we can't easily make setup.py use setuptools.
- #:use-setuptools? #f
- #:configure-flags (list "WXPORT=gtk2"
- "UNICODE=1")
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'chdir
- (lambda _
- (chdir "wxPython")
- #t))
- (add-after 'chdir 'set-wx-out-dir
- (lambda* (#:key outputs #:allow-other-keys)
- ;; By default, install phase tries to copy the wxPython headers in
- ;; gnu/store/...-wxwidgets-3.0.2 , which it can't, so they are
- ;; redirected to the output directory by setting WXPREFIX.
- (substitute* "config.py"
- (("= getWxConfigValue\\('--prefix'\\)")
- (string-append "= '" (assoc-ref outputs "out") "'")))
- (substitute* "wx/build/config.py"
- (("= getWxConfigValue\\('--prefix'\\)")
- (string-append "= '" (assoc-ref outputs "out") "'")))
- #t))
- (add-after 'set-wx-out-dir 'setenv
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (setenv "WXWIN" (assoc-ref inputs "wxwidgets"))
- (use-modules (ice-9 popen) (ice-9 rdelim))
- (let ((port (open-pipe* OPEN_READ
- (search-input-file inputs
- "/bin/wx-config")
- "--cppflags")))
- (setenv "CPPFLAGS" (read-string port))
- (close-pipe port))
- #t)))))
- (native-inputs
- (list mesa ; for glcanvas
- pkg-config))
- (inputs
- `(("gtk+" ,gtk+-2) ; for wxPython/src/helpers.cpp
- ("wxwidgets" ,wxwidgets-gtk2)))
- (synopsis "Python 2 Bindings for wxWidgets")
- (description "@code{wxpython} provides Python 2 bindings for wxWidgets.")
- (home-page "https://wxpython.org/")
- (license (package-license wxwidgets))))
-
(define-public wxsvg
(package
(name "wxsvg")