summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 20:47:18 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:03 -0400
commit0b85c365a2a569a6a87facc420fe8bee52652994 (patch)
tree8e9bccf81c130b29ca81f532021976d9db3c56e7
parenteb36a550e369d1fb0324af3c501070ae6e3b0462 (diff)
downloadguix-patches-0b85c365a2a569a6a87facc420fe8bee52652994.tar
guix-patches-0b85c365a2a569a6a87facc420fe8bee52652994.tar.gz
gnu: Remove python2-mock.
* gnu/packages/check.scm (python2-mock): Delete variable. (python-mock)[properties]: Delete field.
-rw-r--r--gnu/packages/check.scm10
1 files changed, 0 insertions, 10 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 90b8349657..0e2417c400 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -862,18 +862,8 @@ doctest.")
of your system under test with mock objects and make assertions about how they
have been used. This library is now part of Python (since Python 3.3),
available via the @code{unittest.mock} module.")
- (properties `((python2-variant . ,(delay python2-mock))))
(license license:expat)))
-(define-public python2-mock
- (let ((base (package-with-python2
- (strip-python2-variant python-mock))))
- (package/inherit base
- (propagated-inputs
- `(("python2-functools32" ,python2-functools32)
- ("python2-funcsigs" ,python2-funcsigs)
- ,@(package-propagated-inputs base))))))
-
;;; This package is unmaintained (see the note at the top of doc/index.rst).
(define-public python-nose
(package