summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-09 21:08:36 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-09 21:08:36 +0100
commitd019bce1a3e174079ad0ed94e18a0080e632d36b (patch)
tree530cc10c1c4f56879411a243544cd3535469e6aa
parenteb4ed63fc42db5aceaeed3b864bd21d2a304e1d9 (diff)
downloadguix-patches-d019bce1a3e174079ad0ed94e18a0080e632d36b.tar
guix-patches-d019bce1a3e174079ad0ed94e18a0080e632d36b.tar.gz
gnu: emacs-php-mode: Update to 1.24.0.
* gnu/packages/emacs-xyz.scm (emacs-php-mode): Update to 1.24.0. [arguments]: Include "lisp/" directory, and add it to load path before byte-compiling.
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index aeaedc2597..b5785505a5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12313,7 +12313,7 @@ using Imenu, and Compilation mode support for MSBuild, devenv and xbuild.")
(define-public emacs-php-mode
(package
(name "emacs-php-mode")
- (version "1.23.0")
+ (version "1.24.0")
(source
(origin
(method git-fetch)
@@ -12322,8 +12322,17 @@ using Imenu, and Compilation mode support for MSBuild, devenv and xbuild.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0wnkcxg6djy4jvxhshiy1iw6b5cf79pjwjhfd1a060cavhfm4v5c"))))
+ (base32 "0bs9q62bd7885c39v7x1qz3w1fhpmpdgm72xwsk2yygw0ii425nn"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:include (cons "^lisp/" %default-include)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'add-source-to-load-path 'add-lisp-dir-to-emacs-load-path
+ (lambda _
+ (setenv "EMACSLOADPATH"
+ (string-append (getcwd) "/lisp:" (getenv "EMACSLOADPATH"))))))))
+ (propagated-inputs `(("emacs-projectile" ,emacs-projectile)))
(home-page "https://github.com/ejmr/php-mode")
(synopsis "Major mode for editing PHP code")
(description