summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-01 18:45:19 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-03 21:38:42 +0200
commitc304ce6aa11121b1bc0ad067908123688aeba999 (patch)
treefe6d41847e2547fdadc5f0baf445ff3cbb18e25c
parent999b5fb4d266b94c9af4387756a09d23e651606f (diff)
downloadguix-patches-c304ce6aa11121b1bc0ad067908123688aeba999.tar
guix-patches-c304ce6aa11121b1bc0ad067908123688aeba999.tar.gz
gnu: Add java-osgi-resource.
* gnu/packages/java.scm (java-osgi-resource): New variable.
-rw-r--r--gnu/packages/java.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index ef4199cbc4..841122e81c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -4858,3 +4858,31 @@ of primitive types and their wrapper classes, Strings, and DTOs. List, Set,
Map and array aggregates may also be used. The aggregates must only hold
objects of the listed types or aggregates.")
(license license:asl2.0)))
+
+(define-public java-osgi-resource
+ (package
+ (name "java-osgi-resource")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://central.maven.org/maven2/org/osgi/"
+ "org.osgi.resource/"
+ version "/org.osgi.resource-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "0hi0fsc5v99q22bd7lrkvpz1y0ds4w9arjldpwsrcpqvz2js7q2d"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "osgi-resource.jar"
+ #:tests? #f)); no tests
+ (inputs
+ `(("annotation" ,java-osgi-annotation)
+ ("dto" ,java-osgi-dto)))
+ (home-page "http://www.osgi.org")
+ (synopsis "OSGI Resource")
+ (description
+ "OSGi, for Open Services Gateway initiative framework, is a module system
+and service platform for the Java programming language. This package contains
+the definition of common types in osgi packages.")
+ (license license:asl2.0)))