summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 14:56:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:11 -0400
commitb0193c649fa70b31c2c63f82abb7cf9309066b6c (patch)
tree62ee69c27b9e40679a99588f1d9beb608c465b9d
parente7ccfbed19ed385c7687414beb3279d8649d9a97 (diff)
downloadguix-patches-b0193c649fa70b31c2c63f82abb7cf9309066b6c.tar
guix-patches-b0193c649fa70b31c2c63f82abb7cf9309066b6c.tar.gz
gnu: Remove 4store.
* gnu/packages/databases.scm (4store): Delete variable. * gnu/packages/patches/4store-fix-buildsystem.patch: Delete file. * gnu/packages/patches/4store-unset-preprocessor-directive.patch: Likewise. * gnu/local.mk (dist_patch_DATA): De-register them.
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/databases.scm41
-rw-r--r--gnu/packages/patches/4store-fix-buildsystem.patch56
-rw-r--r--gnu/packages/patches/4store-unset-preprocessor-directive.patch16
4 files changed, 0 insertions, 115 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 947669459e..06cf32b916 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -825,8 +825,6 @@ MODULES_NOT_COMPILED += \
patchdir = $(guilemoduledir)/%D%/packages/patches
dist_patch_DATA = \
- %D%/packages/patches/4store-fix-buildsystem.patch \
- %D%/packages/patches/4store-unset-preprocessor-directive.patch \
%D%/packages/patches/a2ps-CVE-2001-1593.patch \
%D%/packages/patches/a2ps-CVE-2014-0466.patch \
%D%/packages/patches/a2ps-CVE-2015-8107.patch \
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 56f6b92b4c..09d825af3e 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -177,47 +177,6 @@
#:use-module (srfi srfi-26)
#:use-module (ice-9 match))
-(define-public 4store
- (package
- (name "4store")
- (version "1.1.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/4store/4store")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1kzdfmwpzy64cgqlkcz5v4klwx99w0jk7afckyf7yqbqb4rydmpk"))
- (patches (search-patches "4store-unset-preprocessor-directive.patch"
- "4store-fix-buildsystem.patch"))))
- (build-system gnu-build-system)
- (native-inputs
- (list perl
- python-2
- autoconf
- automake
- gettext-minimal
- libtool
- `(,pcre "bin") ;for 'pcre-config'
- pkg-config))
- (inputs
- (list glib
- rasqal
- libxml2
- raptor2
- readline
- avahi
- cyrus-sasl
- openssl
- `(,util-linux "lib")))
- ;; http://www.4store.org has been down for a while now.
- (home-page "https://github.com/4store/4store")
- (synopsis "Clustered RDF storage and query engine")
- (description "4store is a RDF/SPARQL store written in C, supporting
-either single machines or networked clusters.")
- (license license:gpl3+)))
-
(define-public ephemeralpg
(package
(name "ephemeralpg")
diff --git a/gnu/packages/patches/4store-fix-buildsystem.patch b/gnu/packages/patches/4store-fix-buildsystem.patch
deleted file mode 100644
index 383baa9461..0000000000
--- a/gnu/packages/patches/4store-fix-buildsystem.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-This patch sets a fixed version to avoid needing Git and the .git/ folder.
-It also removes the creation of "/var/lib/4store", which is not available
-during the install phase in GNU Guix.
-
-Patch by Roel Janssen <roel@gnu.org>
-*** a/configure.ac Wed Feb 4 19:05:24 2015
---- b/configure.ac Wed Mar 23 11:20:38 2016
-***************
-*** 2,13 ****
- # Process this file with autoconf to produce a configure script.
-
- AC_PREREQ([2.50])
-! AC_INIT([4store], m4_esyscmd([./version.sh .version]), [http://4store.org/support/], [4store])
- AC_CONFIG_SRCDIR([src/backend/backend-intl.h])
-! AM_INIT_AUTOMAKE([1.7 std-options -Wall])
- AC_CONFIG_HEADERS(4store-config.h)
-
- # Checks for programs.
- AC_PROG_LIBTOOL
- AC_PROG_AWK
- AC_PROG_CC
---- 2,14 ----
- # Process this file with autoconf to produce a configure script.
-
- AC_PREREQ([2.50])
-! AC_INIT([4store], [1.1.6], [http://4store.org/support/], [4store])
- AC_CONFIG_SRCDIR([src/backend/backend-intl.h])
-! AM_INIT_AUTOMAKE([1.7 std-options foreign -Wall])
- AC_CONFIG_HEADERS(4store-config.h)
-
- # Checks for programs.
-+ AM_PROG_AR
- AC_PROG_LIBTOOL
- AC_PROG_AWK
- AC_PROG_CC
-
-*** a/src/utilities/Makefile.am Wed Feb 4 19:05:24 2015
---- b/src/utilities/Makefile.am Wed Mar 23 14:05:56 2016
-***************
-*** 13,20 ****
- noinst_PROGRAMS = lex-file-verify 4s-rid
-
- install-data-local:
-! mkdir -p $(DESTDIR)@FS_STORE_ROOT@
-! chmod 1777 $(DESTDIR)@FS_STORE_ROOT@
-
- 4s_backend_destroy_SOURCES = backend-destroy.c
- 4s_backend_destroy_LDADD = ../common/lib4sintl.a
---- 13,19 ----
- noinst_PROGRAMS = lex-file-verify 4s-rid
-
- install-data-local:
-! echo "Please create the following directory: " $(DESTDIR)@FS_STORE_ROOT@
-
- 4s_backend_destroy_SOURCES = backend-destroy.c
- 4s_backend_destroy_LDADD = ../common/lib4sintl.a
diff --git a/gnu/packages/patches/4store-unset-preprocessor-directive.patch b/gnu/packages/patches/4store-unset-preprocessor-directive.patch
deleted file mode 100644
index c4b1d6eda4..0000000000
--- a/gnu/packages/patches/4store-unset-preprocessor-directive.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-This patch removes the _XOPEN_SOURCE preprocessor directive as it does not seem to be needed.
-Setting it removes the definition of strdup, which is used in filter-datatypes.c.
-
-Patch by Roel Janssen <roel@gnu.org>
-*** a/src/frontend/filter-datatypes.c 1970-01-01 01:00:00.000000000 +0100
---- b/src/frontend/filter-datatypes.c 2018-04-03 17:39:23.177905592 +0200
-***************
-*** 18,24 ****
- * Copyright (C) 2006 Steve Harris for Garlik
- */
-
-- #define _XOPEN_SOURCE
- #include <stdlib.h>
- #include <string.h>
- #include <math.h>
---- 18,23 ----