summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 20:38:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:03 -0400
commit953a5ea59d7b2b436773f318cc687f03c52b3185 (patch)
tree7fe9714681a2274d3d2cf19446dbade6647d30da
parenta9e9d9f41ce4c82098c27f14e98d13afb6b53b97 (diff)
downloadguix-patches-953a5ea59d7b2b436773f318cc687f03c52b3185.tar
guix-patches-953a5ea59d7b2b436773f318cc687f03c52b3185.tar.gz
gnu: jalv: Use Python 3.
* gnu/packages/audio.scm (jalv)[python]: Delete argument. [inputs]: Use new style. {gtk+-2}: Delete input. {gtk+}: Replace with... {gtk}: ... this. {gtkmm-2}: Replace with... {gtkmm}: ... this.
-rw-r--r--gnu/packages/audio.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 1ba93afdfb..94979a3500 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2306,17 +2306,15 @@ synchronous execution of all clients, and low latency operation.")
"05lycfq0f06zjp5xqvzjz9hx9kmqx72yng1lghh76hv63dw43lcj"))))
(build-system waf-build-system)
(arguments
- `(#:tests? #f ; no check target
- #:python ,python-2))
+ `(#:tests? #f)) ; no check target
(inputs
- `(("lv2" ,lv2)
- ("lilv" ,lilv)
- ("suil" ,suil)
- ("gtk2" ,gtk+-2)
- ("gtk3" ,gtk+)
- ("gtkmm" ,gtkmm-2)
- ("qtbase" ,qtbase-5)
- ("jack" ,jack-1)))
+ (list lv2
+ lilv
+ suil
+ gtk
+ gtkmm
+ qtbase-5
+ jack-1))
(native-inputs
(list pkg-config))
(home-page "https://drobilla.net/software/jalv/")