summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-01 17:09:04 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-03 21:38:28 +0200
commit30deadee1a8d5d073fd35a8637b76e5e7d5ddac7 (patch)
treefefd318b4ba0f7a099f69c226755ebafc15cb084
parentf403d7abdf28d2d6e4446a2989e0d37d023b6b53 (diff)
downloadguix-patches-30deadee1a8d5d073fd35a8637b76e5e7d5ddac7.tar
guix-patches-30deadee1a8d5d073fd35a8637b76e5e7d5ddac7.tar.gz
gnu: Add java-microemulator-cldc.
* gnu/packages/java.scm (java-microemulator-cldc): New variable.
-rw-r--r--gnu/packages/java.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 806f13ab89..fd6d9aa694 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -4716,3 +4716,32 @@ complex transformations and code analysis tools.")
#t)))))
(native-inputs
`(("java-junit" ,java-junit)))))
+
+(define-public java-microemulator-cldc
+ (package
+ (name "java-microemulator-cldc")
+ (version "2.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/barteo/microemu/archive/"
+ "microemulator_"
+ (string-map (lambda (c) (if (char=? c #\.) #\_ c))
+ version)
+ ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1x1apmz38gkppxnwnygwmi12j54v4p258v8ddzn6dldkk7vak1ll"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "microemulator-cldc.jar"
+ #:source-dir "microemu-cldc/src/main/java"
+ #:tests? #f)); Requires even older software
+ (home-page "https://github.com/barteo/microemu")
+ (synopsis "J2ME CLDC emulator")
+ (description "Microemulator is a Java 2 Micro Edition (J2ME) CLDC/MIDP
+Emulator. It allows to demonstrate MIDlet based applications in web browser
+applet and can be run as a standalone java application.")
+ (license (list license:asl2.0
+ ;; or altenatively:
+ license:lgpl2.1+))))