summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-07-24 18:53:03 +0200
committerAndreas Enge <andreas@enge.fr>2015-07-24 18:53:03 +0200
commit10b1f68877b8198e0c1ab8b0ae9142f3b00975dd (patch)
treece54dc794d777e2129ea921e9f1201e50d88adbb
parent9f51293cee7d00c9434e4a32c77034ad3d3887cc (diff)
downloadguix-patches-10b1f68877b8198e0c1ab8b0ae9142f3b00975dd.tar
guix-patches-10b1f68877b8198e0c1ab8b0ae9142f3b00975dd.tar.gz
gnu: Add cm.
* gnu/packages/algebra.scm (cm): New variable.
-rw-r--r--gnu/packages/algebra.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 71e2ca6630..03c575c95b 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -20,6 +20,7 @@
(define-module (gnu packages algebra)
#:use-module (gnu packages)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages mpi)
#:use-module (gnu packages perl)
@@ -61,6 +62,34 @@ multiplication routines such as Toom–Cook and the FFT.")
(license license:lgpl2.1+)
(home-page "http://mpfrcx.multiprecision.org/")))
+(define-public cm
+ (package
+ (name "cm")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.multiprecision.org/cm/download/cm-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1r5dx5qy0ka2sq26n9jll9iy4sjqg0jp5r3jnbjhpgxvmj8jbhq8"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("mpfrcx" ,mpfrcx)
+ ("zlib" ,zlib))) ; Header files included from cm_common.h.
+ (inputs
+ `(("pari-gp" ,pari-gp)))
+ (synopsis "CM constructions for elliptic curves")
+ (description
+ "The CM software implements the construction of ring class fields of
+imaginary quadratic number fields and of elliptic curves with complex
+multiplication via floating point approximations. It consists of libraries
+that can be called from within a C program and of executable command
+line applications.")
+ (license license:gpl2+)
+ (home-page "http://cm.multiprecision.org/")))
+
(define-public fplll
(package
(name "fplll")