summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 14:31:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:11 -0400
commit38cb3572134c673460099a091a93abcb320e497f (patch)
treec0ee826174031e5bca97a242c949569d72e087c4
parentd986c345601654d7f04a5c82611b76c8da1d44aa (diff)
downloadguix-patches-38cb3572134c673460099a091a93abcb320e497f.tar
guix-patches-38cb3572134c673460099a091a93abcb320e497f.tar.gz
gnu: Remove python2-pyfakefs-bootstrap.
* gnu/packages/check.scm (python2-pyfakefs-bootstrap): Delete variable.
-rw-r--r--gnu/packages/check.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 471150c4df..fdf14f7cf2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3056,19 +3056,6 @@ under test to interact with a fake file system instead of the real file
system. The code under test requires no modification to work with pyfakefs.")
(license license:asl2.0)))
-;; This minimal variant is used to avoid a circular dependency between
-;; python2-importlib-metadata, which requires pyfakefs for its tests, and
-;; python2-pytest, which requires python2-importlib-metadata.
-(define-public python2-pyfakefs-bootstrap
- (hidden-package
- (package
- (inherit (package-with-python2 python-pyfakefs))
- (name "python2-pyfakefs-bootstrap")
- (native-inputs '())
- (arguments
- `(#:python ,python-2
- #:tests? #f)))))
-
(define-public python-aiounittest
(package
(name "python-aiounittest")