summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-29 00:34:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-29 00:34:29 +0200
commitdf3e5cfa05c45439fee30375cde21f4c3d32e26b (patch)
treed2e480fc9acb6ee1fc0448ea83f7ea7e4d54f658
parentb64f4a12451062d7436a0463e6c50d1cef4a75ac (diff)
downloadguix-patches-df3e5cfa05c45439fee30375cde21f4c3d32e26b.tar
guix-patches-df3e5cfa05c45439fee30375cde21f4c3d32e26b.tar.gz
gnu: pigx-bsseq: Fix build.
* gnu/packages/bioinformatics.scm (pigx-bsseq)[arguments]: Patch build system in 'autoreconf phase.
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1b118908da..0945bddbe7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11191,6 +11191,15 @@ in an easily configurable manner.")
(modify-phases %standard-phases
(add-before 'bootstrap 'autoreconf
(lambda _
+ ;; This was fixed in commit
+ ;; d56ac732524da659afbbb0972f7a87fa178ae58e, but there is no
+ ;; release with this fix.
+ (call-with-output-file "VERSION"
+ (lambda (port) (display ,version port)))
+ ;; https://github.com/BIMSBbioinfo/pigx_bsseq/issues/181
+ (substitute* "m4/ax_r_package.m4"
+ (("if\\(is.na\\(packageDescription\\(\"PKG\"\\)\\)\\)")
+ "if(system.file(package=\"PKG\") == \"\")"))
(invoke "autoreconf" "-vif")))
(add-before 'configure 'set-PYTHONPATH
(lambda _