summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-29 00:18:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-29 00:18:48 +0200
commitadd551f651cf6c2359baf5493c7a9d920b7d511d (patch)
tree465ed51455a2d2112d5ba729e59dbea24fbe2914
parent66bfe558481a2431810d7a2d2436d06d6f8daab7 (diff)
downloadguix-patches-add551f651cf6c2359baf5493c7a9d920b7d511d.tar
guix-patches-add551f651cf6c2359baf5493c7a9d920b7d511d.tar.gz
gnu: pigx-chipseq: Fix build.
* gnu/packages/bioinformatics.scm (pigx-chipseq)[arguments]: Patch build system.
-rw-r--r--gnu/packages/bioinformatics.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 239a8c13df..ced3b642e9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11094,6 +11094,15 @@ expression report comparing samples in an easily configurable manner.")
(modify-phases %standard-phases
(add-before 'bootstrap 'autoreconf
(lambda _
+ ;; This was fixed in commit
+ ;; 0b1c9f7f2e4d0ff601f1de95ab8b2953f4d5dbc7, but there is no
+ ;; release with this fix.
+ (call-with-output-file "VERSION"
+ (lambda (port) (display ,version port)))
+ ;; See https://github.com/BIMSBbioinfo/pigx_chipseq/issues/176
+ (substitute* "m4/ax_r_package.m4"
+ (("if\\(is.na\\(packageDescription\\(\"PKG\"\\)\\)\\)")
+ "if(system.file(package=\"PKG\") == \"\")"))
(invoke "autoreconf" "-vif")))
(add-before 'configure 'set-PYTHONPATH
(lambda _