summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWiktor Zelazny <wzelazny@vurv.cz>2022-05-18 16:20:23 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-29 23:56:05 +0200
commit6dacd15381f5cb42653c207715b8d5c133f93129 (patch)
treeac43f28c172d6cdb61119ed19f5d559568b534db
parent3d1b2bc740b880c474ee3b178d078a7222315c74 (diff)
downloadguix-patches-6dacd15381f5cb42653c207715b8d5c133f93129.tar
guix-patches-6dacd15381f5cb42653c207715b8d5c133f93129.tar.gz
gnu: Add python-climin.
* gnu/packages/python-science.scm (python-climin): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-science.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 6bc726fc83..1e0910b46f 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2022 Wiktor Żelazny <wzelazny@vurv.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1291,3 +1292,24 @@ build applications with traitlets in combination with the scipy stack.")
(description "This package is an implementation of the Promises/A+
specification and test suite in Python.")
(license license:expat)))
+
+(define-public python-climin
+ (package
+ (name "python-climin")
+ (version "0.1a1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "climin" version))
+ (sha256
+ (base32
+ "1wpjisd5zzi5yvjff02hnxn84822k8sdxvvd33lil2x79wdb36rv"))))
+ (build-system python-build-system)
+ (native-inputs (list python-nose))
+ (propagated-inputs (list python-numpydoc python-numpy python-scipy))
+ (home-page "https://github.com/BRML/climin")
+ (synopsis "Optimization for machine learning")
+ (description
+ "@command{climin} is a Python package for optimization,
+heavily biased to machine learning scenarios. It works on top of
+@command{numpy} and (partially) @command{gnumpy}.")
+ (license license:bsd-3)))