summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-29 16:25:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-29 16:31:09 +0300
commit50970a28b768c98ed45ed0201e201f5da8d993e4 (patch)
tree22f69800e0b4785f866d164905f05e10952fde93
parentc62be7d53041ce03054371fb320688c6f5800596 (diff)
downloadguix-patches-50970a28b768c98ed45ed0201e201f5da8d993e4.tar
guix-patches-50970a28b768c98ed45ed0201e201f5da8d993e4.tar.gz
gnu: wgetpaste: Remove trailing #t from phases.
* gnu/packages/wget.scm (wgetpaste)[arguments]: Remove trailing #t from phases.
-rw-r--r--gnu/packages/wget.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 95baed25a7..a2131785a7 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -100,16 +100,14 @@ in downloaded documents to relative links.")
(substitute* "wgetpaste"
;; dpaste blocks Tor users. Use a better default.
(("DEFAULT_SERVICE:-dpaste")
- "DEFAULT_SERVICE-bpaste"))
- #t))
+ "DEFAULT_SERVICE-bpaste"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(zsh (string-append out "/share/zsh/site-functions")))
(install-file "wgetpaste" bin)
- (install-file "_wgetpaste" zsh)
- #t)))
+ (install-file "_wgetpaste" zsh))))
(add-after 'install 'wrap-program
;; /bin/wgetpaste prides itself on relying only on the following
;; inputs, and doesn't need to execute arbitrary commands, so
@@ -121,8 +119,7 @@ in downloaded documents to relative links.")
,(delete-duplicates
(map (lambda (command) (dirname (which command)))
(list "bash" "mktemp" "sed" "sort" "tee" "tr"
- "wget" "xclip")))))
- #t))))
+ "wget" "xclip")))))))))
#:tests? #f)) ; no test target
(inputs
(list bash-minimal wget xclip))