summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-05-18 17:31:18 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-29 23:56:05 +0200
commit3d1b2bc740b880c474ee3b178d078a7222315c74 (patch)
tree353710559bf1f0a30fc31ba02e23fbbe5706f335
parent40530ffd15ece6ec610a43221293010fe3b9234b (diff)
downloadguix-patches-3d1b2bc740b880c474ee3b178d078a7222315c74.tar
guix-patches-3d1b2bc740b880c474ee3b178d078a7222315c74.tar.gz
gnu: wla-dx: Update to 10.1.
* gnu/packages/assembly.scm (wla-dx): Update to 10.1. [native-inputs]: Use new style. [arguments]: Add custom 'check phase to run run_tests.sh. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/assembly.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index b2830716e1..ca50b00a06 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -342,7 +343,7 @@ package for the Game Boy and Game Boy Color. It consists of:
(define-public wla-dx
(package
(name "wla-dx")
- (version "9.12")
+ (version "10.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -351,12 +352,20 @@ package for the Game Boy and Game Boy Color. It consists of:
(file-name (git-file-name name version))
(sha256
(base32
- "1wlbqv2rgk9q6m9an1mi0i29250zl8lw7zipki2bbi9mczpyczli"))))
+ "1nh2k2xn5fj389gq68f3fxgrxakgn8c6dw2ffqay86s3706hac9w"))))
(build-system cmake-build-system)
- (native-inputs
- `(("sphinx" ,python-sphinx))) ; to generate man pages
+ (native-inputs (list python-sphinx)) ; to generate man pages
(arguments
- `(#:tests? #f)) ; no tests
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'copy-tests-to-build-directory
+ (lambda _
+ (copy-recursively "../source/tests" "tests")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (let ((sh (which "sh")))
+ (when tests?
+ (invoke sh "../source/run_tests.sh"))))))))
(home-page "https://github.com/vhelin/wla-dx")
(synopsis "Assemblers for various processors")
(description "WLA DX is a set of tools to assemble assembly files to