summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-05 18:35:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-05 18:40:48 +0200
commitdf2dc0c41644477c8cc3ccc958b822f8440114ef (patch)
tree7fb6a60840a78eaf5c16157b45816784eb9c6803
parente721122069528b38e9dc901c4ca69acba0df5aea (diff)
downloadguix-patches-df2dc0c41644477c8cc3ccc958b822f8440114ef.tar
guix-patches-df2dc0c41644477c8cc3ccc958b822f8440114ef.tar.gz
gnu: pigx-scrnaseq: Set NUMBA_CACHE_DIR.
This is needed since the update of python-loompy. * gnu/packages/bioinformatics.scm (pigx-scrnaseq)[arguments]: Rename 'set-PYTHONPATH to 'set-additional-environment-variables and set NUMBA_CACHE_DIR.
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5ca1104436..e9778831d2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11145,8 +11145,11 @@ methylation and segmentation.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'set-PYTHONPATH
+ (add-before 'configure 'set-additional-environment-variables
(lambda _
+ ;; Needed because of loompy
+ (setenv "NUMBA_CACHE_DIR" "/tmp")
+ ;; Needed to capture environment
(setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH")))))))
(inputs
(list coreutils