summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWamm K. D <jaft.r@outlook.com>2022-05-19 01:05:22 -0500
committerLudovic Courtès <ludo@gnu.org>2022-05-28 00:02:56 +0200
commitcfc6bcee4c31c3826657a0bab426142800c9bec3 (patch)
tree1c1aea85835cf1ea035a28d7402dd50e849127f4
parentd4158ea63ad6d112c3e95b3dde99608d7bd99148 (diff)
downloadguix-patches-cfc6bcee4c31c3826657a0bab426142800c9bec3.tar
guix-patches-cfc6bcee4c31c3826657a0bab426142800c9bec3.tar.gz
gnu: Add python-gatt.
* gnu/packages/python-xyz.scm (python-gatt): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 04726c7828..fe1896efca 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31805,3 +31805,36 @@ toolkit for Python.")
"This package provides a Python library for parsing, modifying, and
composing subtitles in the SRT file format.")
(license license:expat)))
+
+(define-public python-gatt
+ (package
+ (name "python-gatt")
+ (version "0.2.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "gatt" version))
+ (sha256
+ (base32
+ "0fjf066jixk30fr8xwfalwfnhqpr56yv0cccyypnx2qp9bi9svb2"))))
+ (propagated-inputs (list python-dbus python-pygobject))
+ (build-system python-build-system)
+ (home-page "https://github.com/getsenic/gatt-python")
+ (synopsis "Bluetooth GATT SDK for Python")
+ (description "The Bluetooth @acronym{GATT, Generic ATTribute Profile}
+@acronym{SDK, Software Development Kit} for Python helps you implement and
+communicate with any Bluetooth Low Energy device that has a GATT
+profile. It supports:
+
+@itemize @bullet
+@item Discovering nearby Bluetooth Low Energy devices
+@item Connecting and disconnecting devices
+@item Implementing your custom GATT profile
+@item Accessing all GATT services
+@item Accessing all GATT characteristics
+@item Reading characteristic values
+@item Writing characteristic values
+@item Subscribing for characteristic value change notifications
+@end itemize
+
+Currently, Linux is the only platform supported by this library.")
+ (license license:expat)))