summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Šabič <erik.sab@gmail.com>2022-05-21 12:01:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:00 +0200
commitc5d68c6d12e691bceba60bc9537ea499bb50273d (patch)
treefa542de1330f2ca2a6bdb3eceaeb5dd66297c96e
parent1a6be557010bcf55d1c6d2e38ab1f8b5efe7303b (diff)
downloadguix-patches-c5d68c6d12e691bceba60bc9537ea499bb50273d.tar
guix-patches-c5d68c6d12e691bceba60bc9537ea499bb50273d.tar.gz
gnu: emacs-list-utils: Update to 0.4.6-1.0dec8c0.
* gnu/packages/emacs-xyz.scm (emacs-list-utils): Update to 0.4.6-1.0dec8c0. [arguments]: Remove the upstreamed 'patch-require-cl phase. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/emacs-xyz.scm46
1 files changed, 21 insertions, 25 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 173071102e..977debae51 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18731,31 +18731,27 @@ and @code{erc-send-modify-hook} to download and show images.")
(license license:gpl3+)))
(define-public emacs-list-utils
- (package
- (name "emacs-list-utils")
- (version "0.4.6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rolandwalker/list-utils")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "07hbz2md52ccy95gv4d5n6szrfmpfqf3w4kwqdg2cf54c7kgf7hw"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-require-cl
- (lambda _
- (substitute* "list-utils.el"
- (("\\(require 'cl\\)") "(require 'cl-lib)"))
- #t)))))
- (home-page "https://github.com/rolandwalker/list-utils")
- (synopsis "List-manipulation utility functions")
- (description "This package provides a list manipulation library for Emacs.")
- (license license:gpl3+)))
+ ;; Use a git snapshot until upstream fixes the build with emacs 28.1.
+ ;; See <http://issues.guix.gnu.org/55558>.
+ (let ((commit "0dec8c02962d2591766739e37c5714ba21133093") (revision "1"))
+ (package
+ (name "emacs-list-utils")
+ (version (git-version "0.4.6" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rolandwalker/list-utils")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11nm8649a131bn2kwj4fxkiijdx2d4f1byx7a985zlb3bzdwnaw8"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/rolandwalker/list-utils")
+ (synopsis "List-manipulation utility functions")
+ (description
+ "This package provides a list manipulation library for Emacs.")
+ (license license:gpl3+))))
(define-public emacs-parsec
(package