summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-13 11:59:16 -0300
committerLudovic Courtès <ludo@gnu.org>2020-09-04 11:29:51 +0200
commit9db1b3786feb5669bed67199365d98f97226ba91 (patch)
tree02ecb19c787b8a9ae965413177880a9067acea3e
parentc49025480e00f68f42efe9f018521d15819c02a6 (diff)
downloadguix-patches-9db1b3786feb5669bed67199365d98f97226ba91.tar
guix-patches-9db1b3786feb5669bed67199365d98f97226ba91.tar.gz
gnu: darktable: Add dependency on libavif, ocl-icd.
* gnu/packages/photo.scm (darktable)[inputs]: Add libavif, ocl-icd. [arguments]: Set LD_LIBRARY_PATH for OpenCL. [supported-systems]: Remove i686 which is not supported anymore. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/photo.scm26
1 files changed, 16 insertions, 10 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 4a5d04fbd9..5f97d7e214 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -505,15 +505,19 @@ photographic equipment.")
(string-append (assoc-ref inputs "ilmbase")
"/include/OpenEXR:" (or (getenv "CPATH") "")))
#t))
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (wrap-program (string-append (assoc-ref outputs "out")
- "/bin/darktable")
- ;; For GtkFileChooserDialog.
- `("GSETTINGS_SCHEMA_DIR" =
- (,(string-append (assoc-ref inputs "gtk+")
- "/share/glib-2.0/schemas"))))
- #t)))))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/darktable")
+ ;; For GtkFileChooserDialog.
+ `("GSETTINGS_SCHEMA_DIR" =
+ (,(string-append (assoc-ref inputs "gtk+")
+ "/share/glib-2.0/schemas")))
+ ;; For libOpenCL.so.
+ `("LD_LIBRARY_PATH" =
+ (,(string-append (assoc-ref inputs "ocl-icd")
+ "/lib"))))
+ #t)))))
(native-inputs
`(("clang" ,clang-9)
("desktop-file-utils" ,desktop-file-utils)
@@ -543,6 +547,7 @@ photographic equipment.")
("lcms" ,lcms)
("lensfun" ,lensfun) ;optional, for the lens distortion plugin
("libgphoto2" ,libgphoto2) ;optional, for camera tethering
+ ("libavif" ,libavif) ;optional, for AVIF support
("libjpeg" ,libjpeg-turbo)
("libomp" ,libomp)
("libpng" ,libpng)
@@ -554,6 +559,7 @@ photographic equipment.")
("libxml2" ,libxml2)
("libxslt" ,libxslt)
("lua" ,lua) ;optional, for plugins
+ ("ocl-icd" ,ocl-icd) ;optional, for OpenCL support
("openexr" ,openexr) ;optional, for EXR import/export
("openjpeg" ,openjpeg) ;optional, for JPEG2000 export
("osm-gps-map" ,osm-gps-map) ;optional, for geotagging view
@@ -567,7 +573,7 @@ developer. It manages your digital negatives in a database, lets you view
them through a zoomable lighttable and enables you to develop raw images
and enhance them.")
;; See src/is_supported_platform.h for supported platforms.
- (supported-systems '("i686-linux" "x86_64-linux" "aarch64-linux"))
+ (supported-systems '("x86_64-linux" "aarch64-linux"))
(license (list license:gpl3+ ;; Darktable itself.
license:lgpl2.1+)))) ;; Rawspeed library.