summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
commit83a760dd58fe975fc32b94161ae076a726e8b9a0 (patch)
tree98402afa5832f9c2f2132daab0e0aa0b2a0bb2c7
parent53762a1bfd49ac6434befd1d0bea02e833c64319 (diff)
downloadguix-patches-83a760dd58fe975fc32b94161ae076a726e8b9a0.tar
guix-patches-83a760dd58fe975fc32b94161ae076a726e8b9a0.tar.gz
gnu: guile-wm: Always use the input Guile's effective version.
* gnu/packages/guile-wm.scm (guile-wm)[arguments]: Replace hard-coded version number with that of the "guile" input.
-rw-r--r--gnu/packages/guile-wm.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/guile-wm.scm b/gnu/packages/guile-wm.scm
index fd7a722a28..2487f89f97 100644
--- a/gnu/packages/guile-wm.scm
+++ b/gnu/packages/guile-wm.scm
@@ -95,14 +95,17 @@ dependencies.")
(ice-9 popen))
;; The '.scm' files go to $(datadir), so set that to the
;; standard value.
- #:configure-flags (list (string-append "--datadir="
- (assoc-ref %outputs "out")
- "/share/guile/site/2.2"))
+ #:configure-flags
+ (let ((out (assoc-ref %outputs "out"))
+ (effective ,(version-major+minor
+ (package-version (this-package-input "guile")))))
+ (list (string-append "--datadir=" out
+ "/share/guile/site/" effective)))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'set-module-directory
(lambda* (#:key outputs #:allow-other-keys)
- ;; Install .scm files to $out/share/guile/site/2.2.
+ ;; Install .scm files to $out/share/guile/site/x.y.
(let ((out (assoc-ref outputs "out"))
(effective (read-line
(open-pipe* OPEN_READ