summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2022-05-21 23:25:45 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-27 23:19:13 +0200
commit3a5540a12c68298908c5dd76eb6ec9768c6b541d (patch)
treebf187cbe55ad5077fbb4ddabda79096eaca778a4
parent4f122abfe0732e40f9422cc90c6c067d2825cf0a (diff)
downloadguix-patches-3a5540a12c68298908c5dd76eb6ec9768c6b541d.tar
guix-patches-3a5540a12c68298908c5dd76eb6ec9768c6b541d.tar.gz
gnu: emacs-detached: Update to 0.7.
* gnu/packages/emacs-xyz.scm (emacs-detached): Update to 0.7. (emacs-dtache): Define as a deprecated alias. I have both renamed the package dtache -> detached as well as moving the development from gitlab to sourcehut. This patch reflects those changes, as well as updating to the latest release of the package. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f7fb6aac35..ed1b005d6e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24348,49 +24348,52 @@ indentation and a command to plot the file.")
according to their use.")
(license license:gpl3+))))
-(define-public emacs-dtache
+(define-public emacs-detached
(package
- (name "emacs-dtache")
- (version "0.5")
+ (name "emacs-detached")
+ (version "0.7")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://gitlab.com/niklaseklund/dtache")
+ (url "https://git.sr.ht/~niklaseklund/detached.el")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "05gm5l533y8xr00w3c3i4fbhzhib6i7q2bbnpkm08w1n8a08iaj5"))))
+ "160h60vrpxslw6y290ndc065cc75dab58aq7kjqash94vkifnii2"))))
(arguments
(list
#:tests? #t
#:test-command #~(list "ert-runner")
#:phases
#~(modify-phases %standard-phases
- (add-before 'install 'install-dtache-env
+ (add-before 'install 'install-detached-env
(lambda _
- (install-file "dtache-env" (string-append #$output "/bin"))))
+ (install-file "detached-env" (string-append #$output "/bin"))))
(add-after 'unpack 'configure
(lambda* (#:key inputs #:allow-other-keys)
- (make-file-writable "dtache.el")
- (emacs-substitute-variables "dtache.el"
- ("dtache-env"
- (string-append #$output "/bin/dtache-env"))
- ("dtache-dtach-program"
+ (make-file-writable "detached.el")
+ (emacs-substitute-variables "detached.el"
+ ("detached-env"
+ (string-append #$output "/bin/detached-env"))
+ ("detached-dtach-program"
(search-input-file inputs "/bin/dtach"))
- ("dtache-shell-program"
+ ("detached-shell-program"
(search-input-file inputs "/bin/bash"))))))))
(build-system emacs-build-system)
(native-inputs (list emacs-ert-runner))
(inputs (list dtach))
- (home-page "https://gitlab.com/niklaseklund/dtache")
- (synopsis "Run and interact with detached shell commands")
+ (home-page "https://git.sr.ht/~niklaseklund/detached.el")
+ (synopsis "A package to launch, and manage, detached processes")
(description
- "The dtache package allows users to run shell commands
-detached from Emacs. These commands are launched in sessions, using the
-program dtach.")
+ "The detached package allows users to run processes
+detached from Emacs. It provides integration with multiple built-in modes, as
+well as providing an interface to attach and interact with the processes.")
(license license:gpl3+)))
+(define-public emacs-dtache
+ (deprecated-package "emacs-dtache" emacs-detached))
+
(define-public emacs-dtrt-indent
(package
(name "emacs-dtrt-indent")