summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:08 +0200
commit38bf6c7d0cb588e8d4546db7d2e0bae2ec25183d (patch)
tree5278711b628ceba5b6daadc8d0acacea62f1f74d
parent8ff87f24a73626c13da258b09dee24a962fc5972 (diff)
downloadguix-patches-38bf6c7d0cb588e8d4546db7d2e0bae2ec25183d.tar
guix-patches-38bf6c7d0cb588e8d4546db7d2e0bae2ec25183d.tar.gz
gnu: obs-websocket: Update to 4.9.1.
* gnu/packages/video.scm (obs-websocket): Update to 4.9.1. [arguments]: Update CMakeLists.txt permissions substitution. Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/video.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 61f8bd924d..022c615f49 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3499,7 +3499,7 @@ OBS audio sources.")
(define-public obs-websocket
(package
(name "obs-websocket")
- (version "4.9.0")
+ (version "4.9.1")
(source
(origin
(method git-fetch)
@@ -3509,7 +3509,7 @@ OBS audio sources.")
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "1r47861ma1s3998clahbnbc216wcf706b1ps514k5p28h511l5w0"))))
+ (base32 "0giwhm0rbc578qng4invqqma935zzjlf05msz1gx986aqk654s7k"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no tests
@@ -3519,10 +3519,10 @@ OBS audio sources.")
(lambda* _
(substitute* "CMakeLists.txt"
;; Remove lines that set writeable permissions on outputs.
+ (("PERMISSIONS [^)]*") "")
(("set\\(CMAKE_INSTALL_DEFAULT_DIRECTORY_PERMISSIONS") "")
- (("OWNER_READ.*\\)") "")
- (("PERMISSIONS") ")"))
- #t)))))
+ ;; Ug^WClever hack to comment out the next line, which is ‘)’.
+ (("(OWNER|GROUP|WORLD)_READ .*") "#")))))))
(inputs
(list obs qtbase-5))
(home-page "https://github.com/Palakis/obs-websocket")