summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2022-05-26 22:04:04 -0400
committerChristopher Baines <mail@cbaines.net>2022-05-27 13:57:25 +0100
commit0e953f3332cc862b08ecb2342bdac9976dd6d08c (patch)
tree7aa62b5fca1abdffac0cfb941aa407a42b104a90
parent9bb71eaac0f8665d2e77dc05deae63ed804adfb7 (diff)
downloadguix-patches-0e953f3332cc862b08ecb2342bdac9976dd6d08c.tar
guix-patches-0e953f3332cc862b08ecb2342bdac9976dd6d08c.tar.gz
gnu: nginx-rtmp-module: Use gexps in phases.
* gnu/packages/web.scm (nginx-rtmp-module)[#:phases]: Use gexps and remove trailing #t. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/web.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d4032a96e2..4723d218d4 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -800,24 +800,22 @@ programming language.")))
((#:phases phases)
#~(modify-phases #$phases
(add-after 'unpack 'unpack-nginx-sources
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (lambda _
(begin
;; The nginx source code is part of the module’s source.
(format #t "decompressing nginx source code~%")
- (invoke "tar" "xvf" (assoc-ref inputs "nginx-sources")
+ (invoke "tar" "xvf" #$(this-package-input "nginx-sources")
;; This package's LICENSE file would be
;; overwritten with the one from nginx when
;; unpacking the nginx source, so rename the nginx
;; one when unpacking.
"--transform=s,/LICENSE$,/LICENSE.nginx,"
- "--strip-components=1")
- #t)))
+ "--strip-components=1"))))
(replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((modules-dir (string-append (assoc-ref outputs "out")
+ (lambda _
+ (let ((modules-dir (string-append #$output
"/etc/nginx/modules")))
- (install-file "objs/ngx_rtmp_module.so" modules-dir)
- #t)))
+ (install-file "objs/ngx_rtmp_module.so" modules-dir))))
(delete 'fix-root-dirs)
(delete 'install-man-page)))))
(home-page "https://github.com/arut/nginx-rtmp-module")