summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorantlers <autumnalantlers@gmail.com>2022-04-04 11:26:09 -0700
committerLudovic Courtès <ludo@gnu.org>2022-04-05 20:41:40 +0200
commit0748d3febd315270335c914a4bad44d5e6400036 (patch)
tree8274fdb5cf01c2651e64e0d8694e699fcd36d758
parent3e599b99dad9e747a439162d20c542d141fa7e01 (diff)
downloadguix-patches-0748d3febd315270335c914a4bad44d5e6400036.tar
guix-patches-0748d3febd315270335c914a4bad44d5e6400036.tar.gz
gnu: linux: Allow kconfig options to be strings
* gnu/packages/linux.scm (config->string): add a clause handling strings Allows for the declarative configuration of kconfig options which accept strings, such as CONFIG_MODULE_SIG_KEY. I've enclosed the given string in quotes, but don't do any kind of escaping. See the kernel mailing list for the current state of escaped strings upstream: https://patchwork.kernel.org/project/linux-kbuild/patch/1431003982-992-1-git-send-email-sr@denx.de/ Apologies to those with double-quotes or backslashes in their CONFIG_SYSTEM_*_KEYS. Signed-off-by: antlers <autumnalantlers@gmail.com> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ec68f5c57e..9a81fc4a3d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -767,7 +767,9 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
((option . #t)
(string-append option "=y"))
((option . #f)
- (string-append option "=n")))
+ (string-append option "=n"))
+ ((option . string)
+ (string-append option "=\"" string "\"")))
options)
"\n"))