summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:00 +0200
commit00b6a808b7bf2f5d5d3b6b299ee0d14ff0f09057 (patch)
tree2ae5417392aef5674905282ad864524a90a42c4c
parentb4caea953aaf1d79166b9ebb8e0badc6c4877f90 (diff)
downloadguix-patches-00b6a808b7bf2f5d5d3b6b299ee0d14ff0f09057.tar
guix-patches-00b6a808b7bf2f5d5d3b6b299ee0d14ff0f09057.tar.gz
gnu: guile-xcb: Always use the input Guile's effective version.
* gnu/packages/guile-wm.scm (guile-xcb)[arguments]: Replace hard-coded version number with that of the "guile" input.
-rw-r--r--gnu/packages/guile-wm.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/guile-wm.scm b/gnu/packages/guile-wm.scm
index 911cda8968..63a5b2ce22 100644
--- a/gnu/packages/guile-wm.scm
+++ b/gnu/packages/guile-wm.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
+;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,7 +31,8 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (guix utils))
(define-public guile-xcb
(let ((commit "db7d5a393cc37a56f66541b3f33938b40c6f35b3")
@@ -48,16 +50,17 @@
(base32
"16w4vgzbmnwih4bgfn8rw85ryfvzhc6hyly6bic9sd7hhc82rcnd"))))
(build-system gnu-build-system)
- (arguments '(;; Parallel builds fail.
- #:parallel-build? #f
- #:configure-flags (list (string-append
- "--with-guile-site-dir="
- (assoc-ref %outputs "out")
- "/share/guile/site/2.2")
- (string-append
- "--with-guile-site-ccache-dir="
- (assoc-ref %outputs "out")
- "/lib/guile/2.2/site-ccache"))))
+ (arguments
+ `( ;; Parallel builds fail.
+ #:parallel-build? #f
+ #:configure-flags
+ (let ((out (assoc-ref %outputs "out"))
+ (effective ,(version-major+minor
+ (package-version (this-package-input "guile")))))
+ (list (string-append "--with-guile-site-dir=" out
+ "/share/guile/site/" effective)
+ (string-append "--with-guile-site-ccache-dir=" out
+ "/lib/guile/" effective "/site-ccache")))))
(native-inputs (list guile-2.2 pkg-config texinfo))
(inputs `(("guile" ,guile-2.2)
("xcb" ,xcb-proto)))