summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:11 +0200
commit578d1b6374df8f5f0239f62409e326ae138acd15 (patch)
tree2f788c1684461a54544dbaeefc20226db80aead2
parentee44a72409017f1bb74b1bc4c2e82fe03ac18c5c (diff)
downloadguix-patches-578d1b6374df8f5f0239f62409e326ae138acd15.tar
guix-patches-578d1b6374df8f5f0239f62409e326ae138acd15.tar.gz
gnu: Add python-fastbencode.
* gnu/packages/python-xyz.scm (python-fastbencode): New public variable.
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a661b1403f..6ca759e2e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2016, 2017, 2019 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016, 2017, 2018, 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016, 2017, 2018, 2020, 2021 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
@@ -13725,6 +13725,34 @@ Debian-related files, such as:
JSON Reference and JSON Pointer.")
(license license:bsd-3)))
+(define-public python-fastbencode
+ (package
+ (name "python-fastbencode")
+ (version "0.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fastbencode" version))
+ (sha256
+ (base32 "1r66w3vpmvfmssshjpgqaj2m14c8p94nymr96mwn61idajz9mg5n"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/breezy-team/fastbencode")
+ (synopsis "Python Bencode (de)serializer with optional fast C extensions")
+ (description
+ "The fastbencode Python package implements the bencode serialization
+format for storing and transmitting loosely structured data, originally used
+by BitTorrent.
+
+The format can encode four different types of values: byte strings, integers,
+lists, and dictionaries (associative arrays). It's simple and unaffected by
+endianness,
+
+This package includes both a pure-Python version and an optional C extension
+based on Cython. Both provide the same functionality, but the C version has
+significantly better performance.")
+ (license (list license:expat ; _bencode_py.py
+ license:gpl2+)))) ; __init__.py
+
(define-public python-fastjsonschema
(package
(name "python-fastjsonschema")