summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Henrique Gomes Higino <luishenriquegh2701@gmail.com>2022-05-18 10:32:22 -0300
committerLudovic Courtès <ludo@gnu.org>2022-05-18 22:29:55 +0200
commit42772a2fa7bba87168d8e9e6803d3152b4899acd (patch)
treea326b1d14699877d127cc60c9cdcb45d7d828b2c
parent32916e04f7e1729b7ea5ab768607eb08183c015d (diff)
downloadguix-patches-42772a2fa7bba87168d8e9e6803d3152b4899acd.tar
guix-patches-42772a2fa7bba87168d8e9e6803d3152b4899acd.tar.gz
gnu: lua-luv: Update to 1.43.0-0.
* gnu/packages/libevent.scm (libuv-for-luv): New variable * gnu/packages/lua.scm (lua-luv): Update to 1.43.0-0. [inputs]: Change libuv to libuv-for-luv. [native-inputs]: Update lua-compat-5.3 to 0.10. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/libevent.scm17
-rw-r--r--gnu/packages/lua.scm13
2 files changed, 24 insertions, 6 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index b3a5cd915e..d807315906 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -169,6 +170,22 @@ resolution, asynchronous file system operations, and threading primitives.")
(home-page "https://github.com/JuliaLang/libuv")
(properties '((hidden? . #t))))))
+(define-public libuv-for-luv
+ ;; When upgrading make-lua-luv, also upgrade this. Get the version from
+ ;; https://github.com/luvit/luv/blob/master/CMakeLists.txt
+ (package
+ (inherit libuv)
+ (name "libuv")
+ (version "1.43.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dist.libuv.org/dist/v" version
+ "/libuv-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "194kwq3jfj9s628kzkchdca534rikjw0xiyas0cjbphqmsvjpmwh"))))
+ (properties '((hidden? . #t)))))
+
(define-public perl-anyevent
(package
(name "perl-anyevent")
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index ee4b7727e0..0662b2d064 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2021 Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
+;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -785,7 +786,7 @@ Grammars (PEGs).")
(define (make-lua-luv name lua)
(package
(name name)
- (version "1.32.0-0")
+ (version "1.43.0-0")
(source (origin
;; The release tarball includes the sources of libuv but does
;; not include the pkg-config files.
@@ -796,7 +797,7 @@ Grammars (PEGs).")
(file-name (git-file-name name version))
(sha256
(base32
- "0c65c1lhbl0axnyks3910gjs0z0hw7w6jvl07g8kbpnbvfl4qajh"))))
+ "1yzi4bm845vl84wyv2qw4z1n1v285lgwm681swmp84brfy2s7czp"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; there are none
@@ -813,22 +814,22 @@ Grammars (PEGs).")
(copy-recursively (assoc-ref inputs "lua-compat")
"lua-compat")
(setenv "CPATH"
- (string-append (getcwd) "/lua-compat:"
+ (string-append (getcwd) "/lua-compat/c-api:"
(or (getenv "CPATH") "")))
#t)))))
(inputs
- (list lua libuv))
+ (list lua libuv-for-luv))
(native-inputs
`(("lua-compat"
,(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/keplerproject/lua-compat-5.3")
- (commit "daebe77a2f498817713df37f0bb316db1d82222f")))
+ (commit "v0.10")))
(file-name "lua-compat-5.3-checkout")
(sha256
(base32
- "02a14nvn7aggg1yikj9h3dcf8aqjbxlws1bfvqbpfxv9d5phnrpz"))))))
+ "1caxn228gx48g6kymp9w7kczgxcg0v0cd5ixsx8viybzkd60dcn4"))))))
(home-page "https://github.com/luvit/luv/")
(synopsis "Libuv bindings for Lua")
(description