summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-17 21:52:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-18 00:07:24 -0400
commit0ae9e75c31b22ea55093f4cd05954f366b1f8bcc (patch)
tree4de2c50bab00d5d69379eebc8cf6744e65286c24
parentb6bfe9ea6a1b19159455b34f1af4ac00ef9b94ab (diff)
downloadguix-patches-0ae9e75c31b22ea55093f4cd05954f366b1f8bcc.tar
guix-patches-0ae9e75c31b22ea55093f4cd05954f366b1f8bcc.tar.gz
gnu: emacs-elpy: Disable tests now failing with Emacs 28.1.
* gnu/packages/emacs-xyz.scm (emacs-elpy)[phases] {disable-broken-tests}: Delete the elpy-project-find-git-root-test.el test file. Mark the elpy-company-backend-should-add-shell-candidates, elpy-eldoc-documentation-should-show-object-onelinedoc, elpy-shell-send-file-should-accept-large-strings, elpy-shell-should-echo-outputs as expected failures.
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 529e9329d6..df7bc30bc1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10972,9 +10972,25 @@ indentation guides in Emacs:
(with-directory-excursion "test"
(for-each delete-file
(append (find-files "." "elpy-refactor")
- (find-files "." "elpy-multiedit")
- (find-files "." "elpy-pdb")
- (find-files "." "elpy-promise"))))))
+ (find-files "." "elpy-multiedit")
+ (find-files "." "elpy-pdb")
+ (find-files "." "elpy-promise")))
+ ;; These test fail since upgrading Emacs from version 27 to
+ ;; 28.1 (see:
+ ;; https://github.com/jorgenschaefer/elpy/issues/1982).
+ (delete-file "elpy-project-find-git-root-test.el")
+ (substitute* "elpy-company-backend-test.el"
+ (("elpy-company-backend-should-add-shell-candidates.*" all)
+ (string-append all " :expected-result :failed\n")))
+ (substitute* "elpy-eldoc-documentation-test.el"
+ (("elpy-eldoc-documentation-should-show-object-onelinedoc.*" all)
+ (string-append all " :expected-result :failed\n")))
+ (substitute* "elpy-shell-send-file-test.el"
+ (("elpy-shell-send-file-should-accept-large-strings.*" all)
+ (string-append all " :expected-result :failed\n")))
+ (substitute* "elpy-shell-echo-inputs-and-outputs-test.el"
+ (("elpy-shell-should-echo-outputs.*" all)
+ (string-append all " :expected-result :failed\n"))))))
;; The default environment of the RPC uses Virtualenv to install
;; Python dependencies from PyPI. We don't want/need this in Guix.
(add-before 'check 'do-not-use-virtualenv