summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-10 17:44:32 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:50:39 +0100
commit04661b6931eb3968e6de5cffd444315a82de2a6e (patch)
tree93d6c11ac912422c624f6e81dc8814b757fa91cf
parent773ef90517dba73b350479d1004b96d436af1617 (diff)
downloadguix-patches-04661b6931eb3968e6de5cffd444315a82de2a6e.tar
guix-patches-04661b6931eb3968e6de5cffd444315a82de2a6e.tar.gz
gnu: Add rust-postgres-0.15.
* gnu/packages/crates-io.scm (rust-postgres-0.15): New variable.
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 427efbd631..84015862e5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -27984,6 +27984,38 @@ overloading without macros in Rust.")
UDP.")
(license license:unlicense)))
+(define-public rust-postgres-0.15
+ (package
+ (name "rust-postgres")
+ (version "0.15.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "postgres" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1id6jb56jack7kxivpp3rnjjmkmymmxqadf0h0smgbsixy8dwp8i"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-bytes" ,rust-bytes-0.4)
+ ("rust-fallible-iterator" ,rust-fallible-iterator-0.1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-native-tls" ,rust-native-tls-0.1)
+ ("rust-openssl" ,rust-openssl-0.9)
+ ("rust-postgres-protocol" ,rust-postgres-protocol-0.3)
+ ("rust-postgres-shared" ,rust-postgres-shared-0.4)
+ ("rust-rustc-serialize" ,rust-rustc-serialize-0.3)
+ ("rust-schannel" ,rust-schannel-0.1)
+ ("rust-security-framework" ,rust-security-framework-0.1)
+ ("rust-socket2" ,rust-socket2-0.3))))
+ (home-page "https://github.com/sfackler/rust-postgres")
+ (synopsis "Native, synchronous PostgreSQL client")
+ (description
+ "This package provides a native, synchronous PostgreSQL client.")
+ (license license:expat)))
+
(define-public rust-postgres-protocol-0.3
(package
(name "rust-postgres-protocol")