summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-18 10:24:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-18 10:58:19 -0400
commit894b89c17bef61eec61e96f9c5acdd749aec119b (patch)
treec49be97d25fb0bd84c4db9801bf5d8eaeebbbb52
parentfe9d14552a918ab3d064e56d7cb8f8342e87d2d4 (diff)
downloadguix-patches-894b89c17bef61eec61e96f9c5acdd749aec119b.tar
guix-patches-894b89c17bef61eec61e96f9c5acdd749aec119b.tar.gz
gnu: python-scrapy: Fix indentation
* gnu/packages/python-web.scm (python-scrapy): Fix indentation.
-rw-r--r--gnu/packages/python-web.scm84
1 files changed, 42 insertions, 42 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7636931091..aa510b57b7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6901,52 +6901,52 @@ regular expressions.")
(name "python-scrapy")
(version "2.6.1")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "Scrapy" version))
- (sha256
- (base32 "09rqalbwcz9ix8h0992mzjs50sssxsmmh8w9abkrqchgknjmbzan"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Scrapy" version))
+ (sha256
+ (base32 "09rqalbwcz9ix8h0992mzjs50sssxsmmh8w9abkrqchgknjmbzan"))))
(build-system python-build-system)
(arguments
`(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest"
- ;; requires network access
- "--ignore" "tests/test_command_check.py"
- "-k"
- (string-append
- ;; Failing for unknown reasons
- "not test_server_set_cookie_domain_suffix_public_private"
- " and not test_user_set_cookie_domain_suffix_public_private"
- " and not test_pformat")
- "tests")))))))
- (propagated-inputs
- (list python-botocore ; Optional: For S3FeedStorage class.
- python-cryptography
- python-cssselect
- python-itemadapter
- python-itemloaders
- python-lxml
- python-parsel
- python-protego
- python-pydispatcher
- python-pyopenssl
- python-queuelib
- python-service-identity
- python-setuptools
- python-tldextract
- python-twisted
- python-w3lib
- python-zope-interface))
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest"
+ ;; requires network access
+ "--ignore" "tests/test_command_check.py"
+ "-k"
+ (string-append
+ ;; Failing for unknown reasons
+ "not test_server_set_cookie_domain_suffix_public_private"
+ " and not test_user_set_cookie_domain_suffix_public_private"
+ " and not test_pformat")
+ "tests")))))))
+ (propagated-inputs
+ (list python-botocore ; Optional: For S3FeedStorage class.
+ python-cryptography
+ python-cssselect
+ python-itemadapter
+ python-itemloaders
+ python-lxml
+ python-parsel
+ python-protego
+ python-pydispatcher
+ python-pyopenssl
+ python-queuelib
+ python-service-identity
+ python-setuptools
+ python-tldextract
+ python-twisted
+ python-w3lib
+ python-zope-interface))
(native-inputs
- (list python-pytest
- python-pyftpdlib
- python-sybil
- python-testfixtures
- python-uvloop))
+ (list python-pytest
+ python-pyftpdlib
+ python-sybil
+ python-testfixtures
+ python-uvloop))
(home-page "https://scrapy.org")
(synopsis "High-level Web crawling and Web scraping framework")
(description "Scrapy is a fast high-level web crawling and web