summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlakshmi <lakshmiprasannakumaran@gmail.com>2018-11-06 15:59:01 +0100
committerGábor Boskovits <boskovits@gmail.com>2018-11-06 16:06:42 +0100
commitcddc0300b7fb5fbbc80f45a626073f8372bf491f (patch)
treeb2f28d071ecc6544802f6ae07bfac04a15b39f87
parentfe4fb278b8754b7723a912ed605cd520f1f42457 (diff)
downloadguix-patches-cddc0300b7fb5fbbc80f45a626073f8372bf491f.tar
guix-patches-cddc0300b7fb5fbbc80f45a626073f8372bf491f.tar.gz
gnu: Add r-weights.
* gnu/packages/cran.scm (r-weights): New variable. Signed-off-by: Gábor Boskovits <boskovits@gmail.com>
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index df869794db..8fed911360 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7225,3 +7225,31 @@ R squared measure from L. J. Edwards et al. (2008) is extended to the GLMM
using @dfn{penalized quasi-likelihood} (PQL) estimation (see Jaeger et
al. (2016)).")
(license license:gpl2)))
+
+(define-public r-weights
+ (package
+ (name "r-weights")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "weights" version))
+ (sha256
+ (base32
+ "0186bfpkhxngrshac6bpg37alp6slwhwd43inrm8hqg0vhpfgc4c"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-gdata" ,r-gdata)
+ ("r-hmisc" ,r-hmisc)
+ ("r-mice" ,r-mice)))
+ (home-page
+ "https://cran.r-project.org/web/packages/weights/")
+ (synopsis "Weighting and weighted statistics")
+ (description "This package Provides a variety of functions for producing
+simple weighted statistics, such as weighted Pearson's correlations, partial
+correlations, Chi-Squared statistics, histograms, and t-tests. Also now
+includes some software for quickly recoding survey data and plotting point
+estimates from interaction terms in regressions (and multiply imputed
+regressions). NOTE: Weighted partial correlation calculations pulled to
+address a bug.")
+ (license license:gpl2+)))