summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-01 14:20:06 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:16 +0200
commitcd40c4d6c360ce52aaf006cb1b0f9190cb5e4d14 (patch)
tree524d84ac0fad4bc87546172a25a6a5c9c39232a2
parent11afd13d70389abeadb274639ddfe1166c8ff4b6 (diff)
downloadguix-patches-cd40c4d6c360ce52aaf006cb1b0f9190cb5e4d14.tar
guix-patches-cd40c4d6c360ce52aaf006cb1b0f9190cb5e4d14.tar.gz
gnu: Add ghc-memotrie.
* gnu/packages/haskell.scm (ghc-memotrie): New variable.
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 76e2d22001..1ae8eb993a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -849,6 +849,29 @@ making this package a full replacement for the original newtype package,
and an alternative to newtype-th.")
(license license:bsd-3)))
+(define-public ghc-memotrie
+ (package
+ (name "ghc-memotrie")
+ (version "0.6.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/MemoTrie/MemoTrie-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "157p0pi6rrq74a35mq6zkkycv4ah7xhkbrcmnkb9xf7pznw4aq0x"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-newtype-generics" ,ghc-newtype-generics)))
+ (home-page "https://github.com/conal/MemoTrie")
+ (synopsis "Trie-based memo functions")
+ (description "This package provides a functional library for creating
+efficient memo functions using tries.")
+ (license license:bsd-3)))
+
(define-public ghc-haddock-library
(package
(name "ghc-haddock-library")