summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-01-18 08:53:01 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-01-19 00:39:49 +0100
commitb585e361844e0ab527d10880698ee0489347b1c6 (patch)
tree0ef79d478bffcc14840418e2de9a98a18e2a2df8
parent376c4619cf8ad683fba5d04513a5298c0a77cfdb (diff)
downloadguix-patches-b585e361844e0ab527d10880698ee0489347b1c6.tar
guix-patches-b585e361844e0ab527d10880698ee0489347b1c6.tar.gz
gnu: Add python-fastimport.
* gnu/packages/python.scm (python-fastimport, python2-fastimport): New variables.
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 75c3bc8574..b0601da4db 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10545,6 +10545,27 @@ concurrent HTTP client library for python using @code{gevent}.")
(define-public python2-geventhttpclient
(package-with-python2 python-geventhttpclient))
+(define-public python-fastimport
+ (package
+ (name "python-fastimport")
+ (version "0.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fastimport" version))
+ (sha256
+ (base32 "1aqjsin4rmqm7ln4j0p73fzxifws6c6ikgyhav7r137m2ixsxl43"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/jelmer/python-fastimport")
+ (synopsis "VCS fastimport parser and generator in Python")
+ (description "This package provides a parser for and generator of the Git
+@url{https://www.kernel.org/pub/software/scm/git/docs/git-fast-import.html,fastimport}
+format.")
+ (license license:gpl2+)))
+
+(define-public python2-fastimport
+ (package-with-python2 python-fastimport))
+
(define-public python-twisted
(package
(name "python-twisted")