summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-02-24 17:07:27 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-03-06 03:33:39 +0100
commitb320f7bf06213087886d4f7fb12baccbc399f3e3 (patch)
treecc77d7c4779132833a99f4163ec22d8057a06ca4
parent2aa6d3aeeb49f116aab2757b217cd25fab71d7d6 (diff)
downloadguix-patches-b320f7bf06213087886d4f7fb12baccbc399f3e3.tar
guix-patches-b320f7bf06213087886d4f7fb12baccbc399f3e3.tar.gz
gnu: python-testpath: Fix library location for python2 version.
* gnu/packages/python.scm (python-testpath)[arguments]: Install module in the proper "lib/pythonx.y" location for all Python versions. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/python.scm26
1 files changed, 16 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 181436e399..3066c88549 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5183,20 +5183,26 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(build-system python-build-system)
(arguments
`(#:tests? #f ; this package does not even have a setup.py
+ #:modules ((guix build python-build-system)
+ (guix build utils)
+ (srfi srfi-1))
+ #:imported-modules (,@%python-build-system-modules
+ (srfi srfi-1))
#:phases
(modify-phases %standard-phases
(delete 'install)
(replace 'build
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((dir (string-append
- (assoc-ref outputs "out")
- "/lib/python"
- (string-take (string-take-right
- (assoc-ref inputs "python") 5) 3)
- "/site-packages/testpath")))
- (mkdir-p dir)
- (copy-recursively "testpath" dir))
- #t)))))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((version (last
+ (string-split (assoc-ref inputs "python") #\-)))
+ (x.y (string-join (take (string-split version #\.) 2)
+ "."))
+ (dir (string-append
+ (assoc-ref outputs "out")
+ "/lib/python" x.y "/site-packages/testpath")))
+ (mkdir-p dir)
+ (copy-recursively "testpath" dir))
+ #t)))))
(home-page "https://github.com/takluyver/testpath")
(synopsis "Test utilities for code working with files and commands")
(description