summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2020-09-17 09:27:09 +0200
committerLeo Famulari <leo@famulari.name>2020-09-17 13:25:36 -0400
commita96873565da1e9a7ef95ab06a5774b1207b86ead (patch)
tree191c96f8e7aa6200ba9bbf3cda65549ba985fab3
parent34d150dcb29b85f69982c75f584857adbc52e60d (diff)
downloadguix-patches-a96873565da1e9a7ef95ab06a5774b1207b86ead.tar
guix-patches-a96873565da1e9a7ef95ab06a5774b1207b86ead.tar.gz
gnu: Add python-requests-ftp.
* gnu/packages/python-web.scm (python-requests-ftp): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7926539233..6bd413efca 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2029,6 +2029,28 @@ with python-requests.")
`(;; FIXME: Some tests require network access.
#:tests? #f))))
+(define-public python-requests-ftp
+ (package
+ (name "python-requests-ftp")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests-ftp" version))
+ (sha256
+ (base32
+ "0yh5v21v36dsjsgv4y9dx4mmz35741l5jf6pbq9w19d8rfsww13m"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (home-page
+ "https://github.com/Lukasa/requests-ftp")
+ (synopsis "FTP Transport Adapter for Requests")
+ (description
+ "Requests-FTP is an implementation of a simple FTP transport
+adapter for use with the Requests library.")
+ (license license:asl2.0)))
+
(define-public python-oauthlib
(package
(name "python-oauthlib")