summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-03 21:03:38 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:16 +0200
commit98993f605b3562f4b9df5061da37df4e75a1c4fe (patch)
treeb31cfe0fd01214714aad028c91320692dd4a428f
parent3ff7232ae724a82a774680fa05598685181dec97 (diff)
downloadguix-patches-98993f605b3562f4b9df5061da37df4e75a1c4fe.tar
guix-patches-98993f605b3562f4b9df5061da37df4e75a1c4fe.tar.gz
gnu: ghc-fgl: Replace "--allow-newer" flags.
* gnu/packages/haskell.scm (ghc-fgl)[arguments]: Replace "--allow-newer" configure flags with a phase that patches the Cabal file.
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9bb81cda6d..4ddd6dc47c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3525,8 +3525,15 @@ variety of traversals.")
"1i6cp4b3w7sjk7y1dq3fh6bci2sm5h3lnbbaw9ln19nwncg2wwll"))))
(build-system haskell-build-system)
(arguments
- `(#:configure-flags (list "--allow-newer=QuickCheck"
- "--allow-newer=hspec")))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'update-constraints
+ (lambda _
+ (substitute* "fgl.cabal"
+ (("QuickCheck >= 2\\.8 && < 2\\.10")
+ "QuickCheck >= 2.8 && < 2.12")
+ (("hspec >= 2\\.1 && < 2\\.5")
+ "hspec >= 2.1 && < 2.6")))))))
(inputs
`(("ghc-hspec" ,ghc-hspec)
("ghc-quickcheck" ,ghc-quickcheck)))