summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam <rndd@tuta.io>2020-11-08 12:10:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-11-18 22:48:17 +0200
commit93589b5e43629b3b4caedcce76243c2ee3eca9e1 (patch)
tree61f5eae4622b332b5e1bd358b9cf109174886f0d
parent7ffa5de2c7b11bc91e13388b6c0c8106345615ed (diff)
downloadguix-patches-93589b5e43629b3b4caedcce76243c2ee3eca9e1.tar
guix-patches-93589b5e43629b3b4caedcce76243c2ee3eca9e1.tar.gz
gnu: Add python-telethon.
* gnu/packages/python-xyz.scm (python-telethon): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 629826cd48..c011020a4c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22626,6 +22626,41 @@ a Python library to convert RELAX NG schemata in Compact syntax (rnc) to
equivalent schemata in the XML-based default RELAX NG syntax.")
(license license:expat)))
+(define-public python-telethon
+ (package
+ (name "python-telethon")
+ (version "1.17.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/LonamiWebs/Telethon")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l9fhdrq576vllgi9aam45xzw5xi6jhgdv5zz8i4ygssdp7cm8jl"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "py.test" "-v"))
+ #t)))))
+ (propagated-inputs
+ `(("python-rsa" ,python-rsa)
+ ("python-pyaes" ,python-pyaes)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-asyncio" ,python-pytest-asyncio)
+ ("python-pytest-trio" ,python-pytest-trio)))
+ (home-page "https://docs.telethon.dev")
+ (synopsis "Full-featured Telegram client library for Python 3")
+ (description "This library is designed to make it easy to write Python
+programs that can interact with Telegram.")
+ (license license:expat)))
+
(define-public python-citeproc-py
(package
(name "python-citeproc-py")