summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2017-01-27 21:35:12 +0800
committer宋文武 <iyzsong@member.fsf.org>2017-02-12 13:08:05 +0800
commit92ac2cff825e3854201f6d0396790400364fff0e (patch)
tree6f682ee63003cd25c83d3c6c4d6d8976052425b9
parent4406b6aa90977293f2f99aa3e76ded28445a1a20 (diff)
downloadguix-patches-92ac2cff825e3854201f6d0396790400364fff0e.tar
guix-patches-92ac2cff825e3854201f6d0396790400364fff0e.tar.gz
gnu: Add openvswitch.
* gnu/packages/networking.scm (openvswitch): New variable.
-rw-r--r--gnu/packages/networking.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index c2df3013c3..a10fbfed92 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1060,3 +1060,62 @@ suddenly a lot of network traffic, you can fire up NetHogs and immediately see
which PID is causing this. This makes it easy to identify programs that have
gone wild and are suddenly taking up your bandwidth.")
(license license:gpl2+)))
+
+(define-public openvswitch
+ (package
+ (name "openvswitch")
+ (version "2.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://openvswitch.org/releases/openvswitch-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "036gq741j9kqsjlp693nff838c9wjd1c56nswl9vyyd1lsmj0yrh"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(;; FIXME: many tests fail with:
+ ;; […]
+ ;; test -e $OVS_RUNDIR/ovs-vswitchd.pid
+ ;; ovs-appctl -t ovs-vswitchd exit
+ ;; hard failure
+ #:tests? #f
+ #:configure-flags
+ '("--enable-shared"
+ "--localstatedir=/var"
+ "--with-dbdir=/var/lib/openvswitch")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ (zero? (system* "make"
+ ;; Don't try to create directories under /var.
+ "RUNDIR=/tmp"
+ "PKIDIR=/tmp"
+ "LOGDIR=/tmp"
+ "DBDIR=/tmp"
+ "install")))))))
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2)
+ ;; for testing
+ ("util-linux" ,util-linux)))
+ (propagated-inputs
+ `(("python-six" ,python2-six)))
+ (inputs
+ `(("libcap-ng" ,libcap-ng)
+ ("openssl" ,openssl)))
+ (synopsis "Virtual network switch")
+ (home-page "http://www.openvswitch.org/")
+ (description
+ "Open vSwitch is a multilayer virtual switch. It is designed to enable
+massive network automation through programmatic extension, while still
+supporting standard management interfaces and protocols (e.g. NetFlow, sFlow,
+IPFIX, RSPAN, CLI, LACP, 802.1ag).")
+ (license ; see debian/copyright for detail
+ (list license:lgpl2.1 ; xenserver and utilities/bugtool
+ license:gpl2 ; datapath
+ license:bsd-2 license:bsd-3
+ license:asl2.0)))) ; all other