summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-13 21:53:25 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:46 -0400
commit73728b3942fc29aadd0cc6c8935a6704cf646858 (patch)
tree78ba9fedb603971d4314e8499de0455244033cec
parent1e76c82ca6c59b96210ed72726ec9c9179db409d (diff)
downloadguix-patches-73728b3942fc29aadd0cc6c8935a6704cf646858.tar
guix-patches-73728b3942fc29aadd0cc6c8935a6704cf646858.tar.gz
gnu: python-notebook: Update to 6.4.10.
* gnu/packages/python-xyz.scm (python-notebook): Update to 6.4.10. [phases]{check}: Remove add-installed-pythonpath. [native-inputs]: python-nest-asyncio.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2bcb51a651..ca293f5f54 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13722,13 +13722,13 @@ convert an @code{.ipynb} notebook file into various static formats including:
(define-public python-notebook
(package
(name "python-notebook")
- (version "6.3.0")
+ (version "6.4.10")
(source (origin
(method url-fetch)
(uri (pypi-uri "notebook" version))
(sha256
(base32
- "0zfwr87ndjzmdp9adpc9lby1hdqdkjp2q7c9vff3wiw1dj6kkjfb"))))
+ "03p976xq1l9xf4djwk0snmywd0zck3i6gjngxsl874i8qrmsf214"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -13747,10 +13747,9 @@ convert an @code{.ipynb} notebook file into various static formats including:
(setenv "HOME" (getcwd))))
(replace 'check
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
- ;; These tests require a browser
+ ;; These tests require a browser.
(delete-file-recursively "notebook/tests/selenium")
(when tests?
- (add-installed-pythonpath inputs outputs)
;; Interferes with test expectations.
(unsetenv "JUPYTER_CONFIG_PATH")
;; Some tests do not expect all files to be installed in the
@@ -13767,6 +13766,7 @@ convert an @code{.ipynb} notebook file into various static formats including:
python-jinja2
python-jupyter-client
python-jupyter-core
+ python-nest-asyncio
python-nbconvert
python-nbformat
python-prometheus-client