summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-24 20:56:29 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-07 09:41:21 -0400
commit62646d768d8e4f161c763f379131b2a0a972299a (patch)
treea01e2d7fbf3f0bfc20cf169da1c37856487890ce
parente174191029529d19e7a8a12d749ec6aa2ae9ba3e (diff)
downloadguix-patches-62646d768d8e4f161c763f379131b2a0a972299a.tar
guix-patches-62646d768d8e4f161c763f379131b2a0a972299a.tar.gz
gnu: Add go-github-com-shadowsocks-go-shadowsocks2.
* gnu/packages/golang.scm (go-github-com-shadowsocks-go-shadowsocks2): New variable.
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2acde4adb4..e3816534f3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -74,6 +74,37 @@
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
+(define-public go-github-com-shadowsocks-go-shadowsocks2
+ (package
+ (name "go-github-com-shadowsocks-go-shadowsocks2")
+ ;; Version > 0.1.3 requires go-toolchain v1.16.
+ (version "0.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/shadowsocks/go-shadowsocks2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wzy3ml4ld83iawcl6p313bskzs6zjhz8vlg8kpwgn71cnbv4pvi"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/shadowsocks/go-shadowsocks2"))
+ (propagated-inputs
+ `(("go-github-com-riobard-go-bloom"
+ ,go-github-com-riobard-go-bloom)
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
+ ("go-golang-org-x-net" ,go-golang-org-x-net)
+ ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+ ("go-golang-org-x-text" ,go-golang-org-x-text)))
+ (home-page "https://github.com/shadowsocks/go-shadowsocks2")
+ (synopsis "Shadowsocks tunnel proxy")
+ (description "Go-ShadowSocks is a Go implementation of the Shadowsocks tunnel
+proxy protocol.")
+ (license license:asl2.0)))
+
(define-public go-github-com-riobard-go-bloom
(let ((commit "cdc8013cb5b3eb0efebec85f0e904efccac42df9")
(revision "0"))