summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSughosha <Sughosha@proton.me>2022-05-08 21:41:46 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-16 15:48:09 +0200
commit5ba12f0176300d154b086485ecf363f10f283a9f (patch)
treec64abe5f2b90b5fd6777e9e8d5d6e681a7be9124
parenta588fd6d67c4bbf8d3b51349678278efc1d24d20 (diff)
downloadguix-patches-5ba12f0176300d154b086485ecf363f10f283a9f.tar
guix-patches-5ba12f0176300d154b086485ecf363f10f283a9f.tar.gz
gnu: gcolor3: Fix build with libportal-0.5.
* gnu/packages/patches/gcolor3-update-libportal-usage.patch: New file. * gnu/packages/gnome.scm (gcolor3)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm4
-rw-r--r--gnu/packages/patches/gcolor3-update-libportal-usage.patch55
3 files changed, 59 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index cfb499915a..79019e8564 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1131,6 +1131,7 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-9-asan-fix-limits-include.patch \
%D%/packages/patches/gcc-9-strmov-store-file-names.patch \
%D%/packages/patches/gcc-10-cross-environment-variables.patch \
+ %D%/packages/patches/gcolor3-update-libportal-usage.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
%D%/packages/patches/gd-brect-bounds.patch \
%D%/packages/patches/gd-Revert-fix-303-gdlib.pc.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 654facdbff..ee5d31f5dd 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10321,7 +10321,9 @@ only know by its Unicode name or code point.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1igqmach1vhcrvbpw346pmkbb5kabbb806ssswrvkp569n700wmc"))))
+ (base32 "1igqmach1vhcrvbpw346pmkbb5kabbb806ssswrvkp569n700wmc"))
+ ;; XXX: Remove when upgrading
+ (patches (search-patches "gcolor3-update-libportal-usage.patch"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t))
diff --git a/gnu/packages/patches/gcolor3-update-libportal-usage.patch b/gnu/packages/patches/gcolor3-update-libportal-usage.patch
new file mode 100644
index 0000000000..3e6d33e544
--- /dev/null
+++ b/gnu/packages/patches/gcolor3-update-libportal-usage.patch
@@ -0,0 +1,55 @@
+Fix gcolor3 to work with libportal-0.5
+
+This patch is extracted from upstream, see here
+https://gitlab.gnome.org/World/gcolor3/-/commit/1750369a3fd922aa9db6916207dc460c6f885e14
+
+From 1750369a3fd922aa9db6916207dc460c6f885e14 Mon Sep 17 00:00:00 2001
+From: Michal Vasilek <michal@vasilek.cz>
+Date: Mon, 27 Dec 2021 13:47:14 +0100
+Subject: [PATCH] Update to libportal 0.5
+
+---
+ meson.build | 2 ++
+ src/gcolor3-color-selection.c | 2 +-
+ src/meson.build | 1 +
+ 3 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 6453679..7d6dc50 100644
+--- a/meson.build
++++ b/meson.build
+@@ -7,9 +7,11 @@ dep_gtk = dependency('gtk+-3.0', version: '>= 3.20.0', required: true)
+ dep_libportal = dependency(
+ 'libportal',
+ required: true,
++ version: '>= 0.5',
+ fallback: ['libportal', 'libportal_dep'],
+ default_options: ['gtk_doc=false'],
+ )
++dep_libportal_gtk3 = dependency('libportal-gtk3', version: '>= 0.5', required: true)
+ cc = meson.get_compiler('c')
+ dep_lm = cc.find_library('m', required: true)
+
+diff --git a/src/gcolor3-color-selection.c b/src/gcolor3-color-selection.c
+index 7413850..5df9d54 100644
+--- a/src/gcolor3-color-selection.c
++++ b/src/gcolor3-color-selection.c
+@@ -41,7 +41,7 @@
+ #include <gtk/gtk.h>
+ #include <glib/gi18n.h>
+ #include <libportal/portal.h>
+-#include <libportal/portal-gtk3.h>
++#include <libportal-gtk3/portal-gtk3.h>
+
+ #ifdef ENABLE_NLS
+ #define P_(String) g_dgettext(GETTEXT_PACKAGE "-properties",String)
+diff --git a/src/meson.build b/src/meson.build
+index 3998f68..d488e51 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -42,6 +42,7 @@ executable(
+ dependencies: [
+ dep_gtk,
+ dep_libportal,
++ dep_libportal_gtk3,
+ dep_lm