summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 20:35:11 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:16 +0200
commit16b4b6d1b93cefc565500ff35cac434a9dda21bb (patch)
tree91335b47db2d026f7cf77ed113136eea63370dd5
parentb408c5a768345907f69772e42a75d7e4ecaa97c0 (diff)
downloadguix-patches-16b4b6d1b93cefc565500ff35cac434a9dda21bb.tar
guix-patches-16b4b6d1b93cefc565500ff35cac434a9dda21bb.tar.gz
gnu: ghc-half: Update to 0.3.
* gnu/packages/haskell.scm (ghc-half): Update to 0.3. [native-inputs]: Add ghc-hspec and ghc-quickcheck.
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b942d2d4ce..6327b4fe84 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1447,7 +1447,7 @@ PNG, PNM, TGA, TIFF, XCF, XPM, XV.")
(define-public ghc-half
(package
(name "ghc-half")
- (version "0.2.2.3")
+ (version "0.3")
(source
(origin
(method url-fetch)
@@ -1456,8 +1456,11 @@ PNG, PNM, TGA, TIFF, XCF, XPM, XV.")
version ".tar.gz"))
(sha256
(base32
- "0p4sb7vv9cljv48wlx65wgdnkryrk5d6yfh7g4yrm20w1p449hl5"))))
+ "14r0nx8hm5fic9gz0ybjjw4kyc758zfgvhhwvzsshpx5caq6zch6"))))
(build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
(home-page "https://github.com/ekmett/half")
(synopsis "Half-precision floating-point computations")
(description "This library provides a half-precision floating-point