summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-15 15:56:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-15 15:58:30 +0300
commit00838bd41ce7f1e4bf0d9d65bcf0f96fa781f6f4 (patch)
tree446a2f5e1bfbab4853037c4d57b6959eb3cc3b05
parentc54087a853f6e7f2f755339db50569835a80dc7e (diff)
downloadguix-patches-00838bd41ce7f1e4bf0d9d65bcf0f96fa781f6f4.tar
guix-patches-00838bd41ce7f1e4bf0d9d65bcf0f96fa781f6f4.tar.gz
gnu: efibootmgr: Fix cross compiling.
Fixes <https://issues.guix.gnu.org/55373>. * gnu/packages/linux.scm (efibootmgr)[arguments]: When cross-compiling add make-flags to find and use the correct binaries and libraries.
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 95f2e96f17..eb92ac3f9f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6805,14 +6805,22 @@ interface to the variable facility of UEFI boot firmware.")
(arguments
(list
#:tests? #f ;no tests
- #:make-flags #~(list (string-append "prefix=" #$output)
- (string-append "libdir=" #$output "/lib")
- ;; EFIDIR denotes a subdirectory relative to the
- ;; EFI System Partition where the loader will be
- ;; installed (known as OS_VENDOR in the code).
- ;; GRUB overrides this, as such it's only used if
- ;; nothing else is specified on the command line.
- "EFIDIR=gnu")
+ #:make-flags
+ #~(append (list (string-append "prefix=" #$output)
+ (string-append "libdir=" #$output "/lib")
+ ;; EFIDIR denotes a subdirectory relative to the
+ ;; EFI System Partition where the loader will be
+ ;; installed (known as OS_VENDOR in the code).
+ ;; GRUB overrides this, as such it's only used if
+ ;; nothing else is specified on the command line.
+ "EFIDIR=gnu")
+ #$(if (%current-target-system)
+ #~(list
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
+ (string-append "EXTRAINCDIRS="
+ #$(this-package-input "efivar") "/include"))
+ #~'()))
#:phases #~(modify-phases %standard-phases (delete 'configure))))
(native-inputs
(list pkg-config))