summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-19 01:26:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:58 -0400
commitef4473051e82d94560b38ca76e9a0ad4b7f410ae (patch)
tree2fe56dbfedecc8dca34a3a21fa873b61ad37d002
parentfa3f7073a98d7c37036712becda3167f4db6a2aa (diff)
downloadguix-patches-ef4473051e82d94560b38ca76e9a0ad4b7f410ae.tar
guix-patches-ef4473051e82d94560b38ca76e9a0ad4b7f410ae.tar.gz
gnu: python-readme-renderer: Update to 34.0.
* gnu/packages/python-xyz.scm (python-readme-renderer): Update to 34.0. [phases]{check}: Skip GFM tests for now.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d3f9109ec7..a2713caa0f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27441,14 +27441,14 @@ positioning, and keyboard input.")
(define-public python-readme-renderer
(package
(name "python-readme-renderer")
- (version "32.0")
+ (version "34.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "readme_renderer" version))
(sha256
(base32
- "11av194kgq6mvp2afpapkb6vyn3y14gingmgsp3n10krlspvw4mm"))))
+ "1c75h9znffc2lh4j56yg23l5ifj5l8fbdq3kfigi8vbh45zx3d6z"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -27460,7 +27460,12 @@ positioning, and keyboard input.")
"cmarkgfm>=0.5.0"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
- (when tests? (invoke "pytest" "-vv")))))))
+ (when tests?
+ ;; The GFM tests fail due to slight differences in the
+ ;; generated vs expected HTML due to using a more
+ ;; recent bleach version (see:
+ ;; https://github.com/pypa/readme_renderer/issues/234).
+ (invoke "pytest" "-vv" "-k" "not GFM")))))))
(propagated-inputs
(list python-bleach python-docutils python-pygments