summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-19 11:28:07 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:58 -0400
commit046e5f0d041c9122c0881e8e5d1b5927aa44e9e5 (patch)
tree021452004962f15c4ba7d7daf195321cc5a1f0c5
parentd95db23cb1d657bf017681afc1a674e41c1aa7d8 (diff)
downloadguix-patches-046e5f0d041c9122c0881e8e5d1b5927aa44e9e5.tar
guix-patches-046e5f0d041c9122c0881e8e5d1b5927aa44e9e5.tar.gz
gnu: conan: Update to 1.47.0 and relax PyYAML requirement.
* gnu/packages/package-management.scm (conan): Update to 1.47.0. [phases]{check}: Skip the test_apt_check test. {relax-requirements}: Drop upper bound on PyYAML.
-rw-r--r--gnu/packages/package-management.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index e8d182a3bf..10b0e010de 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
-;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;;
@@ -1112,7 +1112,7 @@ written entirely in Python.")
(define-public conan
(package
(name "conan")
- (version "1.42.0")
+ (version "1.47.0")
(source
(origin
(method git-fetch) ;no tests in PyPI archive
@@ -1122,7 +1122,7 @@ written entirely in Python.")
(file-name (git-file-name name version))
(sha256
(base32
- "153npvj81m1c33gfcv2nry7xhyikxnhjns7lvs525f1x20ck6asg"))))
+ "1zs2xb22rsy5fsc0fd7c95vrx1mfz7vasyg1lqkzyfimvn5zah6n"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1133,7 +1133,9 @@ written entirely in Python.")
(("node-semver==0.6.1")
"node-semver>=0.6.1")
(("Jinja2>=2.9, <3")
- "Jinja2>=2.9"))))
+ "Jinja2>=2.9")
+ (("PyYAML>=3.11, <6.0")
+ "PyYAML"))))
(add-after 'unpack 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
(let ((coreutils (assoc-ref inputs "coreutils")))
@@ -1189,6 +1191,8 @@ written entirely in Python.")
;; This one fails for unknown reasons (see:
;; https://github.com/conan-io/conan/issues/9671).
"and not test_build "
+ ;; This test expects the 'apt' command to be available.
+ "and not test_apt_check "
(if (not (string-prefix? "x86_64" system))
;; These tests either assume the machine is
;; x86_64, or require a cross-compiler to target